1

I've installed the Beta3 of Catalina (and matching XCode) and my shell spews out this error whenever I open a terminal.

objc[1209]: Class NSDataAsset is implemented in both 
/System/Library/PrivateFrameworks/UIFoundation.framework/Versions/A/UIFoundation (0x112c97160) 
and 
/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (0x111d85028). 
One of the two will be used. Which one is undefined.

I understand if not everyone wants to dig into the details of the OS under the hood and I have reported this bug to Apple via Feedback Assistant but I want to understand the issue deeper.

I am not finding other posts about this which leads me to think that perhaps I have manually installed one of these frameworks it both of these framework native to Catalina.

How can I pick apart this error so I can learn how or why this error is logged?

  • 2
    Issues with Catalina should be reported to Apple using the Feedback Assistant. – nohillside Jul 15 at 5:57
  • @nohillside And I have done so. But that being such an obvious issue I am inquiring if one of these libs could have been installed by me through sone SDK perhaps. – cyberwombat Jul 21 at 16:37
  • Also - listing the shell command you issue that generates that error might. Also, since the beta is NDA encumbered, you might not get a proper answer here until general release. – bmike Jul 21 at 18:20
  • @bmike - no shell commands. Just opening any terminal. – cyberwombat Jul 21 at 20:41
  • I suppose what I was hoping is that someone might say that one of these libs came from some external SDK I may have installed prior since I assume most people do not have both libs else I would see this error on google. – cyberwombat Jul 21 at 20:42
1

macOS Catalina adds a lot of under the hood components to better support iOS on Mac apps. Both UIKit and AppKit are installed with macOS 10.15.

I haven't extensively tested the Catalina beta, but my best answer right now would be that it's still an early beta (beta 3 at the time of writing) and errors like this are to be expected.

If you are testing an Xcode project on Catalina, I would assume that your app will (mostly) work correctly, but you should file a bug report if you come across any problems that you think may be a bug in the operating system or SDK.

  • Does opening your terminal generate the same message? That's all I am doing. Not using XCode at all - just opening terminal. – cyberwombat Jul 15 at 2:51
  • I haven't been able to check this yet. Are you still running into this issue on the latest beta? – Jake3231 Jul 21 at 13:30
  • Im reluctant to try new beta as it says "Macbook Air 2019 not supported" - that being what I have and have been unable to find what that means I am holding off on that upgrade. – cyberwombat Jul 21 at 16:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .