-1

Is it possible to install macOS as the guest OS within a VM in VMware Fusion?

I am running macOS Mojave on a Mac mini (2018). I want to run virtual machines inside of which is running macOS Mojave or Catalina. I am not trying to run Microsoft Windows, not at all.

Parallels is unusable with macOS as the guest OS. So I need an alternative.

closed as off-topic by nohillside Jul 14 at 8:33

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must demonstrate a reasonable amount of research & understanding of the problem being solved. Please edit to either a) clearly describe your problem and the research done so far to solve it or b) include attempted solutions plus why they didn't work. In either case, be sure your expected results are clearly presented." – nohillside
If this question can be reworded to fit the rules in the help center, please edit the question.

  • VirtualBox seems to be able to run many versions of MacOS. I am using it for many Unixes and it looks like a very professionnal software (0 crash / 2 years ~= 1 full month of use). – dan Jul 14 at 10:10
  • You should not get excited by one report of a problem. Nearly a 100% of software has bugs. Lot of bugs result from some unique set of circumstances that you hope not to encounter. I'm running High Sierra in Parallels. With Parallels you would need to purchase an upgrade to run Catalina. You need to purchase an upgrade for every new macOS. – historystamp Jul 14 at 18:58
  • @daniel Azuelos I have not been so fortunate running macOS in virtual box. I managed to get one point release of macOS to run in one point release of virtualbox. A change in versions of macOS or VirtualBox resulted in failure. virtualbox runs Linux distros just fine. I have not tried running macOS in Virtual Box in two years. – historystamp Jul 14 at 19:01
  • Have you tried the free version of Parallels in the AppStore? apps.apple.com/us/app/parallels-desktop-lite/id1085114709?mt=12 Hurry, I've heard the free version will not be free much longer. – historystamp Jul 14 at 23:32
  • 1
    @nohillside What unclear about this? Poster heard rumors that there are problems running macOS in Virtual Machines. Wants other user to chime in that they have successfully run macOS Mojave or Catalina in a virtual machine. – historystamp Jul 14 at 23:39
2

Yes

According to this product brochure page comparing the Fusion and Fusion Pro feature sets, there is an item listed that is checked for both editions:

Support for macOS Mojave Host and Guest

I currently run Mojave as a guest OS in VMware Fusion version 11.1 on a Mac mini (2018) with 32 gigs of RAM running macOS Mojave 10.14.5 as the host OS.

screenshot of macOS Mojave running as a guest OS within a VM by VMware Fusion

Fusion offered to create a guest OS using the Recovery volume of the host Mojave. Unfortunately, when I chose that option it then reported an error saying I have no Recovery volume. (I doubt that, as Parallels did successfully make a macOS VM from my Recovery volume.) Anyways, I had Install macOS Mojave.app downloaded in my Applications folder. I dragged that into the Fusion "new" VM dialog box, and it worked to install macOS in the new VM.

On the upside, I have not seen the disappearing mouse pointer as was seen in Parallels as linked in the Question. On the downside, I have not yet been able to resize the virtual display in Fusion despite installing VMware Tools utility within the guest OS; the screen is stuck at 1024 x 768 resolution within the macOS guest OS. These virtualizers never run perfectly smoothly, it seems, there are always problems and limitations.

Tip: As a Parallels customer, you qualify for a discount if you decide to go with Fusion.

  • I have a couple of macOS Mojave VMs. On one I have no issue resizing to get max resolution per window size or in full screen. On the other, where it was an issue, I reinstalled VMware Tools and it no longer has that issue. Also make sure that you give permission for VMware Tools to run in the VM. Also, when I run a Linux Mint 18 VM I get mouse jump issue in both the Host and Guest at times. It's a pain isn the A as I"ve not been able to isolate what causes the issue. Bottom line is I've used VMware products since their inception and there are always may bugs. Never have a version that didn't. – user3439894 Jul 14 at 23:56

Not the answer you're looking for? Browse other questions tagged .