I just got the new MacBook Pro, which was released few days ago. It is running macOS Mojave 10.14.5.

I am trying to install macOS Catalina beta version, either beta or developer beta. I have installed both profiles separately to try, however I get the following error.

I even did a fresh installation of macOS Mojave just to make sure something was not wrong with the installed OS that came with the machine.

Is it because the machine is too new and not recognized? If so, I doubt it as I see this machine in the supported devices for the beta version on Apple's support: https://support.apple.com/en-gb/HT201300

Any idea why am I not being able to install a Beta version of any kind?

enter image description here

enter image description here enter image description here

  • What did it say underneath that not found dialog? Mine says "Your Mac is up to date — macOS Mojave Beta 10.14.6 (currently pb3, released this week) - but this machine cannot do Catalina. Also, what do you have set in Advanced... ?
    – Tetsujin
    Commented Jul 13, 2019 at 17:10
  • @Tetsujin At least you've got the 10.14.6, I can't even get to that...I attached 2 more screenshots.
    – Nima
    Commented Jul 13, 2019 at 17:15
  • I'd make sure you follow this - macrumors.com/how-to/install-the-macos-catalina-public-beta - I can't check it as I have a building full of Mac Pros.. which have been dumped at Catalina :\
    – Tetsujin
    Commented Jul 13, 2019 at 17:16
  • Yes I tried that, no luck... I'm trying to find a direct link to Catalina beta so I can install it through a bootable disk.
    – Nima
    Commented Jul 13, 2019 at 17:44
  • 3
    @benwiggy - I'm pretty sure I wasn't advising anyone to do that. The very term 'dodgy illicit mirror' ought to tell you that.
    – Tetsujin
    Commented Jul 13, 2019 at 18:10

3 Answers 3


I found this... Catalina Link to App Store

Edit: This link now downloads beta 5.

It may help trigger the search for updates but it didn't fix the issue for me either.

Update: I ran the App Store link on my iMac that already has Catalina. App Store opened System Preferences and asked if I wanted to download Catalina. I answered yes and that downloaded the full installer.

From there I made the thumb drive from the command line and when I booted off the thumb drive it tells me that a software update is required for this Mac and clicking software update tells me that there is no update.

Running the installer from within Mojave tells me that "This version of macOS 10.15 cannot be installed on this computer."Catalina Beta Screenshot

Apparently the laptop is really unsupported at this point.

  • Oh I see. Good job finding the app store link. I did the steps earlier you mentioned and I've got the same issue with "cannot be installed on this computer". What Macbook pro are you on?
    – Nima
    Commented Jul 14, 2019 at 11:29
  • 13" 128 GB 2019 base model. It is interesting how the latest OS isn't ready for the latest computer isn't it? Commented Jul 14, 2019 at 22:05
  • @Nima Just ran Software Update and 10.14.6 beta 4 appeared tonight. Just wondering if this appeared for you as well. Commented Jul 16, 2019 at 2:51
  • Indeed - I've seen it last night. So I assume they are still testing the Catalina's beta version on this machine. I've got the same specs as yours btw.
    – Nima
    Commented Jul 16, 2019 at 10:24
  • Catalina Beta just arrived on my MacBook Pro today. Its kind of like Christmas. :-D Commented Jul 16, 2019 at 23:45

This worked for me, finally! https://www.reddit.com/r/MacOSBeta/comments/clb8at/the_requested_version_of_macos_is_not_available/

Execute this command in your terminal:

sudo /usr/sbin/softwareupdate --set-catalog https://swscan.apple.com/content/catalogs/others/index-10.15beta-10.15-10.14-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz

Then, delete the current file in case there is any:

sudo rm /Users/Shared/.SeedEnrollment.plist

Make a new file using nano:

sudo nano /Users/Shared/.SeedEnrollment.plist

Copy paste this in it, then save the file and you can finally see the update.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes.
    – grg
    Commented Aug 7, 2019 at 22:09
  • Done, sorry... Is it okay now ? Commented Aug 7, 2019 at 22:21
  • Excellent, I’ve also included the linked file content rather than depending on another external link, and added quote formatting for the quoted content. +1’d
    – grg
    Commented Aug 7, 2019 at 22:33

For anyone who still struggles with this, if you have more than one user run on your Mac.

  1. Open /Users in the Finder and right-click > Get Info.
  2. Change permission settings to Read & Write. (If you have 3 users then change all 3) enter image description here
  3. Setting Icon > Apply to enclosed items enter image description here
  4. Redo answer from Lounès KSOURI. (Or just check the software update again)

(That how I solved my problem, maybe a bit inappropriate but it just works)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .