0

I am trying to download Xcode from the mac app store but it fails again and again. I am using my mobile hotspot for internet. It has a daily data limit of 2.5 GB but Xcode is of 6.1 GB. Once I put Xcode on download from the app store and it processed till 2 GB and then it failed saying slow internet connection. I also tried to pause the download in between but on resuming, it restarts from the starting. I also tried to download it from Apple's website but that also didn't work. Please help with this issue.

  • dev.to/jahirfiquitiva/direct-download-any-xcode-385o See if this helps. Also, Please add in the question, what didn't work in Apple's website? You can use IIT-K Wi-Fi to install it though. That's how I did it. Now I am using VSCode, due to space crunch. – anki Jul 13 '19 at 8:34
  • 1
    Use a better internet connection which does not have a data limit smaller than the size of the package you are trying to download... – Solar Mike Jul 13 '19 at 10:52
1

You can try to download bittorrent version of Xcode but there's always a risk of downloading files from unknown source and you may not be able to find the latest version, as I could only find Xcode 9.

Side note: In the past, I would've recommended a tool called ADCDownload, which allows you to resume downloads from Apple Developer website. But it hasn't been updated in awhile, and likely no longer working.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .