Hy everyone!

I need help restoring my MBP.

2016 MBP15TB

I made a USB stick with Mojave, restarted with Command+R, went into disk util, and wanted to erase my SSD to start the install. The computer was working fine earlier today, but had a lot of crap on it and I wanted to start fresh. Had about 260GB free space.

Unfortunately this did not work, and the erase process crashed.

Looked online and found a topic here and found out that you can delete the apfs container manually in terminal with diskutil.

Found a YT video explaining it and it worked until the process actually started.

When in gets to 50%, it crashes again and restarts.

Format does not happen. I can try erase from the disk utility and it does the same. No % shown but after unmounting everything it hang for a few secs and crashes again.

Cannot load back to the original OS either.

Also diskutil list shows 22 disks for some reason that i do not understand.

Here is a video on what's happening:


Anyone have any idea what to do? How to clean the SSD for a full clean install? Thank you.

  • Just wondering, how did you make the external installer? Did you use dosdude1's installer creator, or create it by making an .iso out of Install macOS Mojave, and then use dd to install it on a thumb drive? – Sam Jul 12 at 23:47
  • No. I made it on this Mac earlier today with the apple provided terminal command. Downloaded Mojave from the app store and used the terminal command from the support article. Then restated and wanted to erase and install Mojave from the USB. – David Monostori Jul 13 at 0:10
  • That's interesting, would you mind sharing the command? – Sam Jul 13 at 0:11
  • It's the one in this article for Mojave: support.apple.com/en-us/HT201372 – David Monostori Jul 13 at 0:16

This is the official answer from me on what fixed the issue. If you run into this same situation(rare case really) this is how it was fixed. The background: MBP 2016 with TB, updated normally, converted to APFS and had at one point windows running on it with bootcamp.

I decided to format the drive and reinstall clean because i had a lot of clutter on it and moved everything to cloud, so i can have more space.

Followed the apple guideline and made a bootable installer USB. Followed the erase process, and in the middle of that my MBP crashed with a kernel panic. Kernel panic happened with disk utility and terminal. Tried multiple methods. My APFS container was damaged and disk utility was unable to resolve it. The OS was gone, it was not booting. The only sign on the screen was a circle with a diagonal line in it. Recovery still worked.

Took it to apple store and started working on it with genius bar guys. After 3 hours most of them gave up and said needs an ssd repair because this is a hardware issue($800). I was thinking differently, because it was fine a few hours earlier. Then another genius came up with an idea that became the solution.

We connected another macbook pro with a thunderbolt cable to mine, and turned mine on while holding T.

This way we tried to format the drive using the new macbook pro's disk utility. Surprisingly worked, and was able to format the drive in HFS in 15 seconds.

Install still crashed but we were able to use my disk utility and reformat to APFS, and run the installer again. Crashed again.

3rd time we did PRAM and NVRAM reset, run the installer again and no crash, Restarted, with apple logo and a timer. Finished with a working OS and booted to the welcome screen.

Currently its still running, and the partition table cleaned up. If you watched my video, the ghost drives from diskutil list disappeared. The only thing showing now is the current new APFS container, with correct names and sizes.

Drive speed test shows good speeds, no crashes so far. Installed some apps and updates.

I will update this thread if another issue comes up but hopefully it will stay stable for a long time! Cheers! David


Helo, and welcome to Ask Different. (Please excuse my spelling, for some reason Ask Different deletes the word if I start with the word hello.)

Your problem might be that you're restarting into your Recovery Partition instead of your external Installer.

You can boot into your installer by pressing Option when restarting, and then selecting to restart into a volume named something like MacOS Installer. Right now you're restarting into your recovery partition (by restarting while holding Command+R), and then trying to erase your SSD which includes the recovery partition.

As for diskutil showing a strange number of disks, I'm not sure why that happens, but that's not abnormal (it happens to me too).

  • I tried both. Holding down option and booting from the USB does the same thing. I'm at the genius bar and their Mojave installer did the same thing. Diagnostic came back clean that he run with their iPad. – David Monostori Jul 13 at 0:10
  • What do you mean booting from the USB? There is no way to boot from the USB, unless you use option or Terminal – Sam Jul 13 at 0:11
  • @DavidMonostori try restarting while holding down C, which starts from bootable media (such as a thumb drive) – Sam Jul 13 at 0:13
  • I booted from the USB following the instructions in the apple article I linked earlier. This one: support.apple.com/en-us/HT201372 – David Monostori Jul 13 at 0:19
  • That doesn't always work unfortunately. Please try to boot while holding C – Sam Jul 13 at 0:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .