3

I've already tried checking all of my settings, and everything is in order.

Notifications enabled both in and out of Discord, yet I still don't get any notifications.

Help? I've already uninstalled and reinstalled discord, and restarted my phone a few times.

1
  • Have you raised a support ticket for the developers of that software? There might be something on their end that's preventing you from getting the alerts.
    – fsb
    Jul 11 '19 at 20:56
2

This is a Discord “feature” that you can’t turn off. Discord will not send mobile notifications if the desktop app is open (official staff response). Here are some community posts requesting Discord to change this feature:

Discord tries to avoid being annoying in the hopes that it reduces the chance that you uninstall it by not sending push notifications when it thinks you are active at your computer. There is a setting to set the number of minutes Discord waits after you become inactive at your computer prior to resuming push notification in the desktop app under Settings / Notifications. You can only set this down to 1 minute. So you won’t get push notifications until Discord thinks you’ve not been at your computer for at least a minute. But apparently Discord likes to think that many people are using their computers even when they aren’t much of the time.

People report that fully quitting the desktop app of Discord sometimes triggers Discord to start sending push notifications to your phone immediately. You can still use Discord from a web browser without affecting push notifications if you don’t need any features from the desktop app.

1

Try to check the following :

  • check server notification(Beside server name … button, notification setting), makesure no silent.
  • check Discord app notification setting(setting > notification), makesure is turn on.
  • try no force close Discord (leave Discord in "double click/multitasking", do not slip off). If can then is memory no enough problem. Try to uninstall some app.
  • only can receive notification in WiFi environment, try turn on mobile data permission

Just a suggestion.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .