1

I did not find any solution for my problem, so I'm asking this here:

My 2017 iMac won't read a 128 GByte SDXC Card (used to store photos in my Canon 5D Mk IV). It mounts and (most of the time) the files show up in Finder. But if I try to copy or import any of the photos from the card (for example into Lightroom), my mac tells me that it can't read the file because it's corrupt or something. I tried several solutions from this and other forums, but none fixed the problem.

The Filesystem is ExFAT and it's a Lexar (95 MByte/s) SDXC Card. My iMac has no problems to read from a 64 GByte SD Card from Samsung.

My PC and Windows Laptop can copy files from both cards without any problems (so it cannot be corrupt files or a corrupt filesystem).

Any ideas?

Kind regards, Frank

  • Welcome to Ask Different :) Can you try copying via Terminal and see what error message you get? – Nimesh Neema Jul 10 at 19:19
  • 1
    I'd copy everything off it on a PC, reformat it on the Mac, copy the files back and it should work. The Mac is much less forgiving of disk errors, and I'm thinking something is wrong on that SD card. – Steve Chambers Jul 10 at 19:52
  • Once you get all the files off the SDXC card, chuck it in the bin and get a new one. You may be able to reformat it, and use it, but the next time you may not be so lucky and the card may become unreadable on any platform. – IconDaemon Jul 10 at 19:54
  • Thank you for the answers. This is a brand new card and working without problems in both my camera and my laptop. I already tried to format the card with my mac and then taking some pictures with my camera, but the problem stays the same. – Falk Nickenig Jul 11 at 11:40
  • Copying via terminal just says "Input/Output error" for each file – Falk Nickenig Jul 11 at 11:45
-1

I have a similar problem with my iMac 2017 and a 128 GB SD card (SanDisk Extreme Pro SDXC UHS-1).

https://discussions.apple.com/thread/250474343?answerId=250905207022#250905207022

My iMac (OS 10.14.6) refuse to mount the 128 GB card.

It's a brand new card and I use it in my digital camera. The card works as it should in my camera and I'm also able to mount the card on my Macbook Pro (2009) OS 10.11.6.

I have other SD cards (32 GB) that I can mount on my iMac, so I know that there is no hardware problem with my iMac's card reader.

It's weird that the 128 GB card works on an older Macbook Pro which is running an older version of Mac OS. But it doesn't work on a newer model (iMac 2017) which is running the latest Mac OS version.

I think it is a software bug that Apple needs to fix. Although I have a feeling that Apple does not prioritize it. So the best thing is to use another computer than Apple and their latest OS, or to not use 128 GB cards with your Apple computer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .