1

After a few months of not using my iPod (moded with a 128GB SD card) I charged the battery and it plays normally, but now I'm neither able to add nor delete them. First of all I tried to restore with iTunes but nothing happened and nothing was deleted. And then I tried everything, normal format from Disk Utility, then I tried to unmount and perform this commands:

diskutil unmount force /dev/disk4

diskutil zeroDisk /dev/disk4

Nothing happened.

Also tried:

diskutil unmount force /dev/disk4

diskutil eraseVolume ExFAT MyName disk4

on this one i get this error:

Error: -69888: Couldn't unmount disk

Also, after formatting on Disk Utility secure option 2 I get this:

posix reports the operation couldn’t be completed. invalid argument.

I already tried to put iPod on disk mode and perform all the same but it doesn't worked.

After all, nothing was erased and iPod still plays songs normally as if nothing happened.

EDIT: When I try to delete some folders manually I get error -50

  • If this is an old spinny disk iPod 'classic', you should only ever format in iTunes... however, I'm not sure current iTunes will still do it... which might be an issue. I don't know of any iPod that used an SD card. – Tetsujin Jul 9 at 18:07
  • I found this... support.apple.com/HT201544 ...I was trying to find my old iPod, but no joy so far.... – Tetsujin Jul 9 at 18:19
  • Is an iPod Video customized with an SD card, without mechanical hard drive, until now I had no problem adding or removing songs or formating with iTunes, for a while I had installed RockBox without any problems. About the disk mode I have already tried it without any result. – Sokol Jul 9 at 22:08

You must log in to answer this question.

Browse other questions tagged .