0

When I send message on iMessage, it’s sent from my e-mail, which I am logged in iCloud with i.e. my Apple ID, not my phone number. In Settings → Messages → Send and Receive(?), is not my number, just my Apple ID e-mail.

Screenshot from Messages

Screenshot from Send and Receive:

screenshot

receive and send iMessages over

What I have tried:

  • Disabling iMessages & FaceTime on both devices(iPhone and iPad), then restart and then enabling it again.

  • Logging out from AppleID in Settings → Messages → Send and Receive(?).

  • Adding my phone number in Settings → AppleID → Name, Phone Numbers, e-mail.

Neither of these worked!

marked as duplicate by nohillside Jul 8 at 17:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Hi Esea, welcome to Ask Different! Can you include a screenshot of Settings -> Messages -> Send and Receive, and tell us what version of iOS you're on? – JMY1000 Jul 8 at 6:57
  • Of course! prnt.sc/oc6jhq – esea123 Jul 8 at 15:16
  • The screenshot shows no number selected. Does it still not work if you add a phone number and select it under "Empfangen und Senden"? – nohillside Jul 8 at 17:57
  • Problem is that I don't know where to add phone number.. And that's correct, in "Send and Receive" is just email, not phone number (from iphone) with email like it used to be. I've tried to add phone number (as you can see in point 3 in "What I have tried", but that didn't work. – esea123 Jul 8 at 22:26
  • @esea123 Does you iPad has a SIM card? if not, you should turn on text message forwarding on iPhone(if any) – ankiiiiiii Jul 10 at 4:57

Browse other questions tagged .