1

I have typed a 2 page document using Apple's TextEdit on a Mid 2007 iMac running OS X Yosemite 10.10.5. After closing in RTF format and later reopening, I saw many characters (backslashes, etc.) that I didn't type in.

How do I correct that easily (Help section didn't help)?

  • 1
    Without seeing what you're talking about, all I can do is ask... Have you tried using Edit > Find > Find and Replace? Keyboard shortcut: ⌥⌘F – user3439894 Jul 7 at 23:08
  • Firstly, welcome to Ask Different! :) I hope you come to find this site has a lot to offer! In case you haven't already, it's worth taking the time to read the tour. All the best with your question, although it may be worth adding a screenshot to help demonstrate your issue. – Monomeeth Jul 7 at 23:15
  • I would first try to find out why the new characters are there. I use TextEdit a lot on my 2010 iMac and I've never seen this. – jmh Jul 7 at 23:57
  • @jmh, RE "I would first try to find out why the new characters are there."... How is he supposed to do that!? – user3439894 Jul 8 at 0:11
  • I would first check if it is repeatable and then check if any unusual characters were used. I would then save file as plain text instead of rich text and see if strange characters show up. As a start. – jmh Jul 8 at 0:22
2

It sounds like you perhaps opened the doc as plain text instead of rtf. I think you can set it to open as rtf in the Text Edit Preferences.

  • How do you open a RTF document as plain text in TextEdit? Even if I change the extension to .txt it still opens as an RTF document. BTW My TextEdit Preferences for Format is set to Plain Text and it still open it as an RTF document. – user3439894 Jul 8 at 0:46
  • 1
    @user3439894 Try TextEdit > Preferences > Open and Save > check box for "Display RTF files as RTF code instead of formatted text". Or File > Open > Options > check box for "Ignore rich text commands." – Tom Gewecke Jul 8 at 1:29
  • Thanks, I never really took time to see these settings but as they are off by default, you'd think the OP knew he changed at least the one for RTF code, if he in fact did. You should add that information into you answer as it would make for a better answer. – user3439894 Jul 8 at 1:47
0

If you open TextEdit app and under the TextEdit menu item select Preferences. From the preferences panel, click on the "Open and Save" tab at the top of the panel. There is a checkbox for how to display RTF files. Be sure this box is NOT checked. See image below.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .