I tried to follow methods 2 and 3 outlined in this guide https://discussions.apple.com/docs/DOC-3413 on accessing my Time Capsule hard disk from outside of my network.

Unfortunately, both these methods are not working for me. When I try to connect I get a "There was a problem connecting to the server" message. enter image description here

I suspect it may have something to do with the fact that I also use my Time Capsule as my primary router.

More details below:

  • For the Method #2 in Setup section I skipped steps 1-2 because I have a static IP address and thus I don't need a dynamic DNS service. I continued with step 3 "Enable file sharing" & "Share disks over WAN". Then I followed the "To access the AirPort Disk:" section and tried to connect from another Mac connected to the internet using my iPhone data connection. When I tried to connect from Finder's "Connect to Server" and input afp://mypublicstaticIPaddress:8888 I got the "There was a problem connecting to the server" message.

  • For Method #3 I followed the Setup section to the letter and when I tried to connect as per the "To access the AirPort Disk:" section, which I also followed to the letter I got the same "There was a problem connecting to the server" message.

Can anyone suggest what else I may need to do to get either of these methods working?

UPDATE August 30, 2019: now, when trying to connect from Finder by pressing CMD+K and not inputting any connection type prefix like afp or smb, I get a different error: "This file server will not allow any additional users to log on. Try to connect again later." enter image description here

UPDATE January 11, 2020: The issue was that I didn't have a public IP address, my ISP uses carrier grade NAT, so I had to ask for a public IP address.

  • There are 4 methods there, you’ll have to both narrow the scope here and document what precise setup you chose and what help you need. The hold can be reviewed once a substantial edit to clarify this is done. Just @ comment or hit us up in Ask Different Chat – bmike Jul 7 '19 at 18:06
  • Re your point that you suspect it has something to do with the fact that you're also using the Time Capsule as your primary router, have you tested for this? For example, have you got another router you can use temporarily to see if you can access the Time Capsule hard disk remotely while the Time Capsule isn't being used as the router? If so, I'd suggest that'd be a worthwhile troubleshooting step. – Monomeeth Jul 8 '19 at 21:58
  • Thanks for the edits here. I’d be tempted to try method #4 and set up a VPN so you don’t have to mess with the first three options. I know that works, but I have EdgeRouterX as my router and not AirPort. My AirPort just operates in bridge mode behind the router. – bmike Jul 8 '19 at 21:58
  • @Monomeeth I tested it with another router and it didn't work either. – yssup Aug 30 '19 at 13:56
  • @bmike I don't wanna use the method #4 because when I'm out of my home I don't wanna appear under that IP address, which would be the case if I used VPN. – yssup Aug 30 '19 at 14:00

I have maybe a similar problem. Until recently I was with the AEBS 5th gen and accessed from anywhere in the world to the disk that was hooked up. I changed the router with the 6th gen I made the same settings but nothing, I have no access to the disk, tried with another AEBS and again nothing, tried with TC last generation, but still nothing, I can't connect to the router remotely, what did I do, what I didn't change anything either. When I returned for test AEBS 5th gen everything worked perfectly. If anyone has such a problem it would be good to share.

  • @kokotrok Hi, my problems was that I didn't have a public IP address, wherefor I had to ask my ISP. I'm not sure what could be your problem, though. – yssup Mar 22 '20 at 11:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .