0

I was working copy my photos to my external SSD hard drive from my iPhone. I created a new photo library on SSD(USB connected) and start import from iPhone. But SSD partitions were unmount by itself and showed me an error. So I unplugged the SSD from USB and replug two times and continue import. Last time SSD initializing time extended and I could not wait and unplug the SSD from USB port.

After all this, When I plug the SSD to USB port again, I am giving "The disk you inserted was not readable by this computer" error.

enter image description here

enter image description here

  • I tried MiniTool Partition Wizard but it could not find partitions.
  • I tried EaseUS Partition Master 12.10 but it could not find.
  • I tried Acronis Disk Director 12.5 but it could not find.

The SSD partitions filesystem was NTFS.

How can I get back partitions?

  • It rather sounds like the drive was dying & the constant power interruptions have pushed it over the edge. If you could install it internally on any computer, you may at least be able to get some SMART data from it. USB cannot transmit SMART. – Tetsujin Jul 7 at 16:47
  • I installed it a windows computer but It could not show partitions. Disk management just show "uninitialized". – Savas Adar Jul 7 at 18:31
  • Since NTFS is windows, wouldn’t you want to take that to a windows specific repair tool and / or data recovery tool or service? I’m not sure why we would be the best place to Ask this, but I suppose it’s not off topic if you primarily use the drive with a Mac. – bmike Jul 7 at 21:06
  • I used both windows and macos for recover it but I couldn't recover yet. I guessed this is an issue about macos first but I guess this is a partition table issue. But Why macos cause this, I did not understand the reason. – Savas Adar Jul 7 at 21:14
  • I don't understand what you mean by this. "I was working copy my photos to my external SSD hard drive from my iPhone" How was the ssd connected to your iPhone. Yet when you post an image of disk utility, you are on a mac. What third party utility were you using to write to the ntfs disk? – historystamp Jul 8 at 3:38
1

I saved my SSD partitions with TestDisk

My partition table did gone and My SSD has two partitions, first one is NTFS and second one is mac os extended.

And I save my partition table like this guide.

https://www.cgsecurity.org/wiki/TestDisk_Step_By_Step#Partition_table_recovery

  • I was about to suggest this! Thank you for answering your own question. – brunobhr Jul 16 at 23:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .