1

So, this is me, after two days having tried almost every possible solution from the internet and the Apple Support team.

I have a 2016 Macbook Air. It has worked greatly for all this time. And until wednesday (four days ago), I haven't updated since El Capitan. I thought updating to Mojave would be a good idea. Yesterday in the morning I turned on the mac. Forbidden sign. (Circle+Slash). Restart. Again, and again, and again. Cmd+R. Recovery mode. Trying to reinstall Mojave: the Macintosh HD is encrypted and asks me for the password. Dialog box opens for me to type and...
JUST CAN'T TYPE.
Can't click over the text box. Nothing. I restart to the same point to see if there was a keyboard problem. Try Terminal. It types. I try Disk Utility. In order to make any change, it asks me the password, but the same beautiful dialog box in which I can't write anything. I create a partitioned APFS volume from the same disk. It works. I install Mojave in it. I start it correctly. When I go to finder, it states that the Macintosh HD (the other disk) is encrypted and blocked. In order to unlock it, the same dialog box in which, I CAN'T TYPE.

I google and google. I chat with the Apple Care team. They call me. Then they connect me with their manager, the superior service. They ask me to restart, to create a parallel startup disk in an external drive. I do it. I install Mojave in it. The same loop again. I try

resetpassword

in Terminal in recovery mode, for the Macintosh HD. It's possible. I do it by connecting to icloud. (It was encrypted and accesible to get the pass by icloud). Now it appears 'mounted'. I try

diskutil apfs unlockVolume /dev/disk2s1

(this solution) Can't.

I try reinstalling Mojave in the disk when 'mounted' by resetting password again. It fails. Forbidden sign again. Now I'm trying the kernel solution from this question, but there's something I might be doing wrong, because I can't get to the list of the kext extensions.

I am lost. And I need to recover the data from the last three weeks before my last backup. I can't lose that info. If I could just recover that, and lose all of the extra stuff, It won't be a problem.

Do you have any input? Trying won't hurt me :) Thank you!

EDIT: When starting pressing Cmd+S, these are the errors:

BuildUser(): error building a user of type 0x20010008  
ERROR: no panel or special users!  
End OpenKernelRootVolume  
ERROR!!!Load prelinked kernel with status 0x800000000000000e  
Error loading kernel cache (0xe)  
  • Hey francres! Please edit your question to make it a bit more legible by removing the rant commentary (like the first para). I agree such conditions can be frustrating, but cleaner posts help in answering. Also, about the last part, please use code formatting. – ankii Jul 6 at 20:21
  • 1
    Thank you @ankiiiiiii – francres Jul 6 at 20:30

You must log in to answer this question.

Browse other questions tagged .