1

I have a Mac mini running 10.14.5 as a server. In System Preferences / Sharing I set up a shared folder on second internal drive HFS+ formatted drive for time machine backups. Backing up and entering the Time Machine backups works fine from three different clients all running 10.14.5. All backups are encrypted. On the server I can mount the sparsebundle and read the backup (so I have the right key).

Now I replaced one client and want to restore a backup. During the setup I can connect with my file server user to the server and see all three clients, but when I select one of the clients, I get the message "some backups cannot be opened". I never get asked for the encryption key.

Following are my settings:

  • File Sharing: ON at "smb://server.local"
  • Share files using SMB: ON
  • Share files using AFP: OFF
  • Shared Folder Advance: Share as Time Machine destination on, Share over SMB, only encrypted SMB connections OFF
  • Shared Folder Permissions: two user can read and write, admin & everyone can read
1

Is the new 'replaced' client running on the same level of OS as your other clients?

I ran into the same error message when trying to restore a backup, and only got past it when I first upgraded the OS on the new hard drive to the same level as the prior hard drive was running when the most recent back up was made. That is, I skipped restoring files to the computer until I completed initializing the new drive, then upgraded the OS, and finally went back and restored applications and documents.

1

Try it with AFP ON. Although AFP is deprecated, it has been shown to be more reliable with Time Machine over networks than SMB.

1

Is your 'replaced client' the exact same machine name and user as before? if not, you may not have permission to access. The alternative is to take the new client an 'restore from Time Machine' when booted from the recovery partition. This will, of course, wipe the existing data from the hd.

  • I tried "Restore from Time Machine". This way I get one prompt to enter my file server login and a second prompt to enter my encryption key. But the restore fails half way through. I would be satisfied to just restore one user via Migration Assistant, but it never ask for the encryption key. The new client is the exact model like the old one. – Sebastian Semmler Jul 9 at 11:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .