5

I have an iPhone 7 Plus running iOS 12.3.1.

Have been through a few posts about Wi-Fi problems, but this is quite peculiar.

When connecting to a free/unsecured Wi-Fi access point, the checkbox ✓ (shown to the left of the SSID) comes quickly. But then, the Wi-Fi symbol (that replaces the 4G) in the Status bar takes always about 2 minutes to get set.

Irrespective of whether the connection requires a logging-in, this would take around 2 minutes. Connecting to a secured network (WPA2, etc.) is much faster.

I thought that might have something to do with captive.apple.com (used to trigger a login page) and tried to set manual DNS addresses (e.g. 8.8.8.8), but the connection takes that 2 minutes anyway.

Other people around could connect much faster to an unsecured network.

Is that a known problem? Is there a way to fix it?

Here's what I have already tried

  • "Forget that network" from the Access point menu.
  • "Reset Network settings" from general settings.
  • Reboot iPhone.
  • Toggled auto-join.
  • set manual DNS for the connection
  • For my SE, it happens when the access point is at a distance. Is that so in your case ? It might be a known problem but doesn’t seem to me, fixable by options other than you listed. – ankii Jul 5 at 17:43
  • 1
    Happens even when the AP is close... – Ring Ø Jul 5 at 17:46
  • I am glad to learn that I am not the only one with this weird issue. I have had the very same problem for years now. My IPhone SE will also take about 2 minutes to get set when trying to connect to unsecured WiFi’s. Like in your case, the tick appears next to the network I am trying to connect and after waiting for a minute or two the hotspot login page will load. I never managed to get a solution... I think this issue started to happened with my old phone, an iPhone 4s, and I am convinced that this problem was transferred from the backup of my old iPhone when I updated to the the SE... – Julio Gil Jul 10 at 22:15
  • ...Do you remember if this was happening to you also with your previous iPhone? Good to know that I network restore did not solve the problem... I have the feeling that a full restore will solve the problem but I am not sure if I want to restore the phone from scratch and loose everything in it (not knowing for sure if this will resolve the issue)... and to be honest, after all this time I have got used to it! I hope however that someone out there has been able to solve the issue without such a drastic measure and can share it with us! Thanks in advance – Julio Gil Jul 10 at 22:15
  • Hi @JulioGil, I think it was not happening with my previous phone (6+), and believe the problem could have come from an iOS upgrade. – Ring Ø Jul 11 at 11:02

You must log in to answer this question.

Browse other questions tagged .