0

My MacBook Air is not working after installing macOS Catalina. I tried everything to erase the hard drive using Disk Utility and diskutil command, but it won't just let me.

I tried booting into Internet Recovery mode, and reinstall macOS, but no success. I also noticed lots of weird partitions in the diskutil list option.

How do I resolve this issue?

I believe it has to do with gpt command, but I'm not familiar with using it. I also tried using GParted, but it kept giving me input/output error.

Disk Util List GPT -R Show enter image description here enter image description here enter image description here

  • All the "weird partitions" (disk3 -> disk21) are ram disk because you are booted into recovery. Don't worry about them - it is normal. disk1 you don't want to look at as it is a synthesized disk not a real one. Your fdisk /dev/disk0 and gpt -r show disk0 shows corrupt/missing partition table though. What error do you get exactly when you try to erase it from recovery? – lx07 Jul 5 at 15:49
  • i can't erase the hd at all tried to verify/repair no success as well ... the Disk Utility shows two partition one macOs and the other called macOs - Data ( Weird ) both won't be erased or formatted ! tried to do it through disk utility and diskutil command through terminal ! one of the errors i get is there's no map ? so do i have to fix the HD through gpt command first or what to do ? Thanks a lot for replying :) – Ala Al Moosawi Jul 6 at 11:52
  • i managed to wipe the ssd using linux rescue live ... by using dd if=/dev/urandom of=/dev/sdx bs=8M && sync this command – Ala Al Moosawi Jul 8 at 17:33

You must log in to answer this question.

Browse other questions tagged .