1

I have a 1TB SSD on macOS High Sierra 10.13.6 with the following APFS partitions:

$ diskutil list
/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk2         300.0 GB   disk0s2
   3:                 Apple_APFS Container disk1         254.0 GB   disk0s3

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +254.0 GB   disk1
                             Physical Store disk0s3
   1:                APFS Volume macOS High Sierra       225.1 GB   disk1s1
   2:                APFS Volume Preboot                 23.9 MB    disk1s2
   3:                APFS Volume Recovery                519.5 MB   disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4

/dev/disk2 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +300.0 GB   disk2
                             Physical Store disk0s2
   1:                APFS Volume macOS Mojave            241.4 GB   disk2s1
   2:                APFS Volume Preboot                 49.0 MB    disk2s2
   3:                APFS Volume Recovery                1.0 GB     disk2s3
   4:                APFS Volume VM                      20.5 KB    disk2s4

SSD APFS partitions

I would like to resize the macOS Higher Sierra partition highlighted above to ideally take up all the free space dynamically, which I tried to do using the command:

$ diskutil apfs resizeContainer /dev/disk1 0
Started APFS operation
Error: -69743: The new size must be different than the existing size

Trying to enlarge using a fixed size does not work either:

$ diskutil apfs resizeContainer /dev/disk1 500g
Started APFS operation
Aligning grow delta to 246'000'209'920 bytes and targeting a new physical store size of 499'999'997'952 bytes
Determined the maximum size for the targeted physical store of this APFS Container to be 253'999'788'032 bytes
Error: -69771: The target disk is too small for this operation

Neither Time Machine nor FileVault is enabled.

1

For me it looks like you need to resize the container first. So something like

$ diskutil apfs resizeContainer /dev/disk0s3 500g

should help to avoid the error message you get on your second try.

I've got not much knowledge about the diskutil, but as far as I know Apple software overall, this seems to be the step you are missing here.

0

As an educated guess after reading around, the likely reason that the High Sierra container could not be resized was that it was not contiguous with the free space.

I have now zeroed-out Mojave and cloned the contents of High Sierra to there, whereupon I can resize that partition to occupy the free space.

Problem solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .