1

Setup Macbook Pro retina 13 A1502, SSD 128Gb Running Yosemite, but currently doing the update for high sierra.

Problem: Question marked folder appear after I left it for 2 days, battery run out (left it on sleep I think with minimal battery). It showed me a black screen I turned off&on again and folder with question marked appeared. I tried to reinstall using recovery tools, doesn't even show a selectable disk. Tried to Verify and Repair, nothing.

I created a bootable external OS X, from which I'm asking this, and I partitioned the SSD into 1. Curious thing: OS X was in a different partition from the ssd. Another curious thing is that the sdd disappears after I try something. At some point I think it was in the hardware diagnose I found a error that pointed that EFI was broken. I ran sudo gpt -r show disk0s2 and this showed

  start       size  index  contents
      0  236568496     

EDIT: The disks images I have (the Apple SSD long name)
disk0s2

(External disk long name)
disk1 (renamed by me trying to follow a solution)

Disk2
OS X Base System

The result of the disk verifying tool

"The Partition Map needs to be repaired because there is a problem with the EFI system partition's file system"  

The Hardware diagnostic result

Reference code vdh002

Running gdisk sudo gdisk /dev/disk0s2

GPT fdisk (gdisk) version 1.0.4

Partition table scan:
  MBR: not present
  BSD: not present
  APM: not present

I tried the answers provided to similar questions here, here, and here. None of them resolved my problem.

I guess I need to rebuild the EFI? What do I need to do?

You must log in to answer this question.

Browse other questions tagged .