2

The Touch Bar on my MacBook Pro is actually reflecting changes depending on the software context and showing the right buttons. However, it won't respond to my inputs.

I've tried to reset it via Terminal and all the potential solutions that I found on the Internet, but unfortunately none of them worked.

Could you please help me out to make it operational again?

I am running macOS Mojave 10.14.1.

  • 1
    What is the version of macOS running on your MacBook? – Nimesh Neema Jul 2 at 9:00
  • Thanks @NimeshNeema, it's Mojave, 10.14.1 – dev Jul 2 at 9:01
  • 1
    You can update to the current public release i.e. macOS Mojave 10.14.5 and see if fixed the issue. – Nimesh Neema Jul 2 at 9:03
  • I know it's hard to know, but do you think that'll fix it, @NimeshNeema? – dev Jul 2 at 9:05
  • 1
    I don’t know if it would, but it could and it should. – Nimesh Neema Jul 2 at 9:06
1

You are currently running macOS Mojave 10.14.1 which is among the initial releases, and is generally buggier.

Try updating to the current public release 10.14.5, which has addressed a lot of bug fixes. This could potentially fix the issue you are encountering.

1

You can check there is any issue with the hardware components which are connected to the touch bar by using fn key. Soon after you hit the key that should display in the touch bar. In that case you can decide this issue is either software or hardware issue.

  • Thanks @Binoyya, FN keys are appearing in the Touch Bar as soon as I hit the button, however they won't work if I hit them, I am afraid. – dev Jul 2 at 13:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .