0

Through some failures trying to remove Bootcamp I've found myself with a 289GB Macintosh HD and a 201GB "Container disk1". I initially tried to erase the extra volume, thinking it would then give me an option to resize the space into MacintoshHD but apparently not, even in recovery mode. When I delete the volume it just leaves behind the container. I guess APFS works differently.

My main Macintosh HD drive is APFS Encrypted if that makes any difference. Id like to reclaim the entire 201.95GB from Container disk1 back into Macintosh HD.

enter image description here enter image description here

1

You did not include an image for the container holding the Macintosh HD volume. If you select Show All Devices in the View pulldown, then this container will appear. If the Physical stores for this container is disk0s2, then you can apply my answer.

Enter the following commands.

diskutil apfs deleteContainer disk0s3
diskutil eraseVolume free none disk0s3
diskutil apfs resizeContainer disk0s2 0
  • Following your instructions to reveal the other container it was indeed disk0s2 as you suspected, and following your instructions worked perfectly. Thank you! – matthewrk Jul 3 at 16:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .