1

My situation: I successfully installed Windows 10 on a Samsung T5 external SSD (size of 1TB) which I can boot into using my MacBook Pro 13" (2017 model w/ 4 Thunderbolt 3 ports). Under Windows, the disk is partitioned as: - EFI Healthy Primary (or something to that effect) 200MB - Primary (Bootcamp C:) ~999GB or so (NTFS format)

Under the MacOs (Mojave in my case) the disk shows as one volume (Bootcamp), under the device name (which still shows as Samsung Portable etc. etc.), and it says 25GB or so used (which makes sense as that's the Windows10 OS, and 975GB Free.

What I want:

I installed WIn10 on the external for those rarer occasions I need Windows, but now I feel 1TB space is too much. I want to re-purpose quite a bit of space in the Samsung SSD for the Mac. Specifically I would like to partition so that I have

  • a TimeMachine volume (say 500MB - my MBP is only 256GB)
  • Extra space for saving other Mac files (I'm happy to make this exclusive to Mac, but can also think about using exFAT format for common use)
  • The rest of space (say 200-250GB) for the Windows10 OS as is. (basically I want to shrink Windows to a smaller size)

Is there a way I can safely do what I want without messing up the installation of the Win10 OS in the SSD? It was a tedious process to achieve and I already messed it up once. I first had partitioned in Windows, creating a clearly defined volume destined for the MBP. I then tried to partition that from the Mac, and somehow it gave me an error while erasing the partition (out of space?), and it actually caused me to lose the EFI volume that Windows needed to boot. That little bit seems to be indiscernible, and invisible to the MacOS and must have been tampered with. It rendered the external SSD unbeatable for Windows!

So, after having re-installed everything, can anyone recommend a safe method to tamper with the partitions now, without messing up the windows installation already residing in the SSD? Thanks

1

The safest was is to do this from within Windows. You want to shrink your Windows partition until it is 200-250GB and the rest is free space.

The easiest way to do this is to go to Disk Management in Windows, right click on the Windows partition and select "Shrink Volume".

If this doesn't allow you to shrink sufficiently (sometimes there are unmovable files) you can install the free utility Minitool Partition Wizard (again in Windows) which will move these files for you during reboot.

There is a full tutorial of both methods taken from Partition Wizard website here : Two Easy and Effective Ways to Free Shrink Windows Partition

macOS will not let you partition a drive if the EFI partition is less than 200MB (while Windows will by default create a 100MiB EFI partition) which would explain your previous problem.

As you say the EFI partition is now 200MB you can create your 2 new partitions in the newly reclaimed free space either in Windows or macOS Disk Utility as you prefer. If you make a exFAT partition this can be formatted from either OS but the Time Machine partition must be formatted (erased) as HFS from within macOS.

  • Thank you very much for taking the time to answer my question. See, I did all that, shrank the volume and the rest of the space I created as a new volume under Windows. I admit I don't remember exactly what format I used, but I named it so I could recognise it from within Mac. Then in Mac, under Disk utility, I identified that partition and tried to erase it and reformat it as a Mac drive, but it gave me an error (I think in DU's tool the space mismatched what Windows was identifying as correct number? - I don't know...). The error said "not enough space" – user507866 Jun 30 at 21:08
  • (Part 2) After that the EFI partition in Windows (which for some reason during that 1st installation attempt came out to be only 100MB) vanished, which rendered the external SSD unbootable as Windows, though I could tell the Windows system was still in there. Anyway, you think I'll have better luck now? Should I try to match numbers as Mac's Utility identifies them, it feels like maybe I tried to create a larger partition than the one I had allocated (from within Windows) and DU somehow went beyond and erased the EFI... – user507866 Jun 30 at 21:10
  • If your EFI partition is 200MB then macOS should have no problems with partitioning. Perhaps shrink the Windows partition (in Windows) so you have 750GB or so unallocated space then make/format the new partitions in macOS. Then it will be easy to see you are creating them in free space not erasing wrong one. If you still get a "not enough space" error then edit the exact message into your question. – lx07 Jun 30 at 21:17
  • Thanks. So I followed your recommendation and used the MiniTool.I also followed your very last suggestion and I left the cleared disk space as unallocated. Unfortunately the Disk Utility in MacOS does not "see" it, and now only recognises the external ssd as Bootcamp (as it should - it's Windows) but of only the reduced size that I gave it in Windows. the rest of the drive is invisible to Mac. Any trick so I can mount it and format it? Or should I go back to MacOs and then format it (I presume as exFat or Fat32) so can Mac can detect it? Also, it seems Windows only saw 931GB of total space... – user507866 Jun 30 at 21:52
  • 1
    "it seems Windows only saw 931GB" - this is normal. Windows shows space as GiB (powers of 2) while macOS shows GB (powers of 10). 1000GB = 931GiB. You could try making the 2 new partitions in unallocated space in Windows and format them ExFAT. Then see if you can reformat the Time Machine one HFS in macOS. – lx07 Jul 1 at 11:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .