7

Ok... tell me it's not just me, when I launch Firefox Developer Edition [68.0b13] in macOS Catalina [beta 2] I get the error message that it can't open because it's from an unidentified developer.

So, I try to go to the file in Application and right-click open and confirm that I want to open. The base program opens but there is an updater sequence that Firefox tries to open that hits the same wall as before.

I've even gone to Security and Privacy and told it to open anyway. Still nothing.

Does anyone know how to overcome this and get FDE to launch or am I just screwed until Apple and Mozilla figure their stuff out?

  • 1
    It is a beta - ask on the Apple beta forums – Mark Jun 26 at 13:01
  • Doing that too. :) – zpeters Jun 26 at 13:03
  • 1
    Two unreleased beta software versions don't work well together. It's to be expected. Have you reported this on the Mozilla bug reporter? – fsb Jun 26 at 13:12
11

Ok... I figured it out.

Disable the block

sudo spctl --master-disable

Launch Firefox and allow the update to complete then re-enable the block. I bet this will also resolve other software not opening as well.

sudo spctl --master-enable

Thanks to @Mark for the reminder about the Beta forums.

  • 1
    love you guys I had the same problem with firefox and whatsapp. problem solved thanks – Daniele Calabrese Jun 27 at 2:19
1

I had the same problem with Firefox 67.0.4. Catalina refused to recognise Mozilla so I downloaded of an earlier version Firefox (66) from the Mozilla site and replaced the latest version in Applications. It then worked fine. Firefox then updated to 67.0.4 and continued working fine

1

in catalina beta 5 (shipped yesterday) issue is even higher, firefox (release, beta, nightly) does not work at all! steps: 1. clean every single dependency 2. install latest and greatest, clean install 3. start firefox

expected: should run fine actual: you see main window, as soon as you click anywhere, exception occurs, application would not run at all, you are (of course) shown the error reporting dialog, but nothing beyond that

  • 1
    again, just making sure, with new beta 5, firefox is dead in the water and unlike before, this is not about creating a child process for update, it does not work at all anymore. apple is obviously smoking, i suspect that mongodb 32bit is deprecated, no 32bit processes are allowed (which is beyond stupid, it is fascist) – user962247 Aug 2 at 22:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .