2

I'm trying to mount a USB stick in single-user mode (thankfully there's nothing wrong with my Mac, I'm just trying some stuff out). These are the commands I've been running:

$ mount -uw / 
$ mkdir /Volumes/drive
$ mount -t msdos /dev/disk2 /Volumes/drive
mount_msdos: Unsupported sector size (0)

The USB drives connects to my system properly and is visible in /dev/. I've reformatted the drive as HFS and got the same error message. I've also tried another USB stick formatted in both FAT32 and HFS, to no avail. I assume this must mean that I'm doing something wrong here, but a quick Google search shows that most people succeed using this approach.

I'm running MacOS Sierra 10.12.6 on a mid 2012 MacBook Pro.

  • You should connect the drive to you mac before you boot. I remember this was problematic. You should try recovery mode. Attach drive. boot in recovery mode. go to terminal. Should find the drive attached. – historystamp Jun 25 at 22:07
1

How about formatting the usb stick with exFAT format. That works for me where I have to copy/read in both my mac and windows OS's

  • Thanks! Now I just have to somehow figure out a way to turn off SIP in single user mode :) – theone Jun 26 at 15:15
  • @theone, RE: "Now I just have to somehow figure out a way to turn off SIP in single user mode", IIRC you can only turn SIP off while booted from the Recovery HD. – user3439894 Jun 26 at 15:21
  • @user3439894 oh, thanks! Do you know if the terminal in recovery mode has root access too? – theone Jun 26 at 15:30
  • @theone, Terminal in Recovery HD is by default a root session, hence why you do not need to use sudo. – user3439894 Jun 26 at 15:41
  • Have you try out the disk utility function for the process that you have mentioned here? – Binoyya Jun 27 at 6:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .