4

I sometimes run into an issue where I connect an external monitor via HDMI, and my Macbook Pro's sound is now routed to the monitor instead of my headphones or the internal speakers. Worse, sometimes this means that the volume control buttons stop working (even mute!)

I never, ever, want sound going through an external monitor. The internal speakers are better than most monitor speakers, anyway.

Is there a way to prevent this happening?

2

In the sound section of system preferences, make sure that "Internal Speakers" is selected.

enter image description here

  • Yes, that's how I change the current output. But that doesn't prevent the same thing happening with future monitors. – Steve Bennett Jun 26 at 5:05
  • Sorry, I'm not aware of a way to permanently disable the HDMI audio output. This hints that it may be tied to what is set as the main monitor, not sure if it would be helpful. I swapped between my two monitors and no matter which one I plugged in (or both), my MacBook display remained as the main monitor and the audio output didn't change. – hot pineapple juice Jun 26 at 5:40
1

I made an app for this. It allows you to pin input/output so it cannot be changed for every particular set of connected devices.

New contributor
Pavel S. is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Welcome to Ask Different, and thanks for your contribution. Your duplicate answers have been flagged, so I've taken a look. It's good you've disclosed your affiliation with the app, but please be careful with how often you promote it. If users see no other contributions except for ones promoting your software, you may run into problems. All the best. – Monomeeth 2 days ago

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .