0

I'm using macOS Mojave. Apparently I've changed a setting - but can't figure out which one - that forces Mail to automatically pop up in the active desktop when there's new email.

For instance, I'm in a desktop with Safari maximized, I receive an email and the Mail app automatically splits the screen and shows the new email.

This happens even when I'm connected to a projector and in a meeting. considering I've even turned on the Do Not Disturb mode when mirroring TV and projectors, it's super strange.

Could you please help me find this option to prevent Mail pop up when there's a new email?

1

IF you go to Notifications > Mail you should be able to change the Mail Alert Style to "None" to avoid mail alerts altogether.

Source: https://discussions.apple.com/thread/4306641

  • Thanks Darison. I need those banners. I just don't want the Mail application to pop up and take up my desktop. as long as it stays in the desktop it was, showing notifications is fine. – Reyraa Jun 25 at 7:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .