0

Out of the blue my 2014 MacBook Pro running macOS Mojave is not booting.. it keeps freezing on the Apple logo.

I’ve tried the following already:

  1. Ran it in recovery mode - ran first aid on the disk, all is well.
  2. Verbose mode - ran it, text comes up real quick for a second and then it jumps to the Apple logo and the text disappears.
  3. Tried running it in safe mode but it won’t work - just goes to the Apple logo as usual. Tried checking if I have a firmware password - I don’t.
  4. Reset the NVRAM and PRAM.
  5. Performed a Hardware Test (pressing D during startup) - all is well.

Please help me out here.. I’m really trying to fix this but nothing seems to work. Maybe someone here will have a clue how to fix this.

Thanks!

1

Not sure if it helps, but it happens to me sometimes too, or stuck in black screen when it attempts to start in BootCamp. I realized if I take out or unplug some usb cable from the laptop, it would start up normally. I also noticed it happened much less after I disabled a usb flash drive in Device Manager that I don't plug in and use all the time.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .