1

I'm trying to deal with an old Mac Pro (I'm not sure how old) which will not boot - it shows the grey screen with the Apple logo, and the progress bar rushes up to 50%, then slowly creeps up to 100%, but then just hangs at 100%. I'm not sure what version of OSX is on it, but I think it's High Sierra.

I'm able to boot into Recovery Mode (holding Cmdr after the boot chime), and that seems to work fine, but when I try to start in Safe Mode by holding Shift, the grey screen with the Apple logo appears, the progress bar gets to about 50%, and then the machine turns off. I've tried several times with the same effect.

I've removed all external peripherals (except monitor, mouse and keyboard), and a couple of internal HDDs that just have data on, I've also tried removing each RAM stick one at a time, all with the same symptoms.

Does failing to start in Safe Mode imply anything specific that I can try, or just general disaster?

I've tried reinstalling the OS via Recovery Mode, which looked to be working fine, the progress bar got "2 minutes remaining", then the Mac rebooted, and seemed to hang on the screen with the Apple logo for a while, but eventually came into something like Recovery Mode, showing the Installer Log, with a variety of errors, including:

  • A slightly worrying-looking log message (from a clearly highly competent developer :D):
*** HACK HACK HACK --- APFS Verify / Repair Disabled For Encrypted Disks --- HACK HACK HACK ***
  • The following two lines sequentially:
FileSizerGetHFSFolderSize Error Enumerating: Error Domain=NSCocoaErrorDomain Code=260 "The file "MacOS" couldn't be opened because there is no such file." UserInfo={NSURL=file:///Volumes/OS/System/Library/Extensions/AppleIntelHD3...
Can not connect to /var/run/systemkeychaincheck.socket: No such file or directory
  • A whole bunch of lines like this, with the final element of the file path (F1) replaced with several other 2-character values (which look like hex):
Path enumeration error: Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory" (/Volumes/OS/private/var/db/uuidtext/F1)
  • The final error before the crash, just before a bunch of call stacks seems to be:
*** Terminating app due to uncaught exception 'FileSystemEnumerationFailure', reason:'The file system enumeration encountered an invalid post-order directory'
  • Have you tried simply overlaying the current OS from recovery? Also - specifically which Mac Pro & what OS? – Tetsujin Jun 22 at 17:21
  • @Tetsujin - just tried that and edited my question with the outcome; going to retry reinstalling the OS, then maybe try reinstalling it on a different hard drive, unless you have another suggestion to try first? – DaveyDaveDave Jun 22 at 17:48
  • tbh, I have no clue what the whole scary terminal-style output means. I'd definitely go for a new drive & install from scratch, then see how Time Machine copes with a migration. If like me you have a pile of HDs but few SSDs, I'd 'waste' an HD & clone to SSD after I'd proved it to work. [patience required, HDs are geriatrically slow ;) – Tetsujin Jun 22 at 17:54
  • I actually have a spare SSD that's exactly the same as the current one, because my wife (who's Mac it is, hence I don't know much about it) insisted on having two for no good reason, but for some reason that I couldn't figure out at the time, the Mac would never recognise both of them together, so I just took the second one out. Of course, now I need to find it... – DaveyDaveDave Jun 22 at 17:58

You must log in to answer this question.

Browse other questions tagged .