1

I recently installed macOS Catalina 10.15 Beta 1. Now, when I try to launch my MongoDB application by running:

> mongod

I get the following error:

enter image description here

I have attempted to go to Security & Privacy and hit the Open Anyway button, but I get the same error.

Any thoughts on how to launch the application from the command line?

  • 1
    Have you tried opening it with CTRL pressed and select Open? – fsb Jun 21 at 21:40
  • Unable to open it with CTRL pressed because I have to open mongod server from the command line as there is no app in the applications. – zpeters Jun 24 at 20:21
0

Throw away your installation (saving any database files you need / export them) and then install the version from https://brew.sh

brew install mongodb
mongod --config /usr/local/etc/mongod.conf

You should be able to get v4.0.3 running without error and then compare if your distribution is compatible or needs adjustment if you can't use the mainline version for macOS.

Installing the program from the command line bypasses the gatekeeper checks and such and might be easier while the beta is new.

  • So... that produced another problem. Apparently my homebrew was hosed too. I threw ALL of it away. I mean ALL. I burned the whole thing down, erased the HD, reloaded macOS Mojave, upgraded to Catalina [10.15b2], reloaded homebrew and mongoDB. I guess I had a good deal of detritus all over my system that was preventing the original use. Good news is that I have a clean system to work from now. :) – zpeters Jun 24 at 20:25
  • Awesome! I’ve heard many brew survive the upgrade, but I’m glad a clean start worked and you didn’t have to assume it was just a mongo mess. – bmike Jun 24 at 22:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .