0

I used to be able to connect to a shared folder on a local Windows PC from my MacBook Air (Early 2015) by doing Finder > Go > Connect to Server or +K and then typing smb://hostname/folder and connecting as Guest.

This method worked without fail for years but it suddenly doesn't work anymore since the Mojave update 10.14.5 (18F132). I can still get to the name/password prompt as usual, but after I pick Guest and click Connect I get the following error:

There was a problem connecting to the server "hostname".

Check the server name or IP address, and then try again. If you continue to have problems, contact your system administrator.

  • I have tried to reboot both machines, without success
  • The same thing happens when I try to connect with an actual user account instead of Guest
  • The same thing happens when I use the server's IP address instead of hostname
  • The server can be pinged
  • The server doesn't show up in Finder's Network page

To confirm this is a mac-side issue I installed the FE File Explorer app on my iPhone and was able to instantly find the server and connect to the shared folder as Guest.

Any ideas on how to solve this?

  • See if this works: swissmacuser.ch/… – IconDaemon Jun 21 at 14:44
  • @IconDaemon Yes this works to properly mount the folder with a username/password. However Guest doesn't work and the server still doesn't show up in Finder's Network view. Thanks for helping! – matheanswer Jun 21 at 18:57

You must log in to answer this question.

Browse other questions tagged .