This question is related to External drive does not mount after plug off without eject, but the difference is that in my case, the drive did not appear in the Disk Utility application nor in diskutil list. Furthermore, I had a strong suspicion that the problem was caused by a poweroff while the external drive wasn't (fully) unmounted, because Finder was showing a warning about disconnecting before unmounting for both partitions of the drive.

When I switched it on, the drive would briefly spin up and then spin down again, but none of the software on my mac would confirm that it was connected.

There are lots of (free) tools available online that promise to help with recovering compromised disks, including some that are provided by disk manufacturers. However, in this case, none of the programs I could find appealed to me, for at least one of the following reasons in each case:

  • It is only for Windows, or it requires creating a bootable flash drive before you can run it.
  • Its documentation does not clearly state that it will be able to find a disk that doesn't already show up on your mac.

I'm asking this question retroactively to share the solution I found. If you know of a different solution that worked in your case, please feel welcome to share as well!

1 Answer 1


Reading the man page of diskutil, I found a command that I thought might provide at least some diagnostics on what was wrong:

diskutil activity

When you run this command, it will start monitoring all disk activity and report back to you until you stop it again.

I ran this command and switched off the bricked external drive. Nothing happened.

I switched the external drive back on while the command was still running. Now, I saw the following sequence of events repeat several times (leaving out the information that came with the events):


and finally a few times


followed by


which was also the last event before I switched the drive back on.

This seemed promising, so I took a peek in the Finder and lo and behold, both partitions of the drive were there!

This was my first attempt to mount the disk while running diskutil activity and the third attempt in total since the problem started. I don't know whether diskutil activity actually fixed the problem or that this was just my "lucky try", but if you run into the same problem as I did, at least this is something you can try!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .