0

The right arrow key () on my 2017 MacBook Air has suddenly stopped working for all my apps (everything else is fine). I think it is a system or detection problem, but I cannot think of any ideas as to why this happened. It was working just fine a few hours ago. I tried resetting my NVRAM following the instructions in the Apple Support document, Reset NVRAM or PRAM on your Mac but it didn't work.

I am currently running macOS Mojave. I have tried using an external keyboard which reproduced the problem, ruling out any hardware related issue.

What could be the possible causes of this? How do I resolve it?

UPDATE: The right arrow key () works in combination with the modifier keys.

  • Welcome to Ask Different :) What is the make and model of your Mac? What is the version of macOS running? You can find this information by going to Apple menu (towards the top of your screen) → About This Mac. – Nimesh Neema Jun 21 at 10:39
  • 1
    Try another keyboard - make sure it's not hardware. – Tetsujin Jun 21 at 10:40
  • @NimeshNeema My mac is MacOS X Mojave on MacBook Air 13-inch 2017 – Bytes1024 Jun 21 at 10:53
  • @Tetsujin Thanks for pointing that out, I tried a different keyboard and it still does not respond. – Bytes1024 Jun 21 at 10:54
  • To further debug, try using an onscreen (software) keyboard and see if you can reproduce the issue? One is built into macOS. Simply go to System Preferences app → Accessibility → Keyboard → Accessibility Keyboard, and check Enable Accessibility Keyboard (as depicted here). – Nimesh Neema Jun 21 at 11:17

You must log in to answer this question.

Browse other questions tagged .