Running the release version of macOS Catalina some SMB shares will not connect when they did on Mojave. I noticed this first after updating to the Catalina 10.15 Beta (19A487l), I am no longer able to connect to my network drive via SMB.

This is the error:

There was a problem connecting to the server "ServerName". The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.

However, I am still able to connect to the network drive from a Windows 10 machine and a macOS Mojave machine.

Is anyone else having this issue? Is it an issue with Catalina or is there something else I can do to try to resolve this?


6 Answers 6


The solution is in Catalina release note


NetBIOS is disabled in macOS 10.15 to speed up mounting, browsing, and connecting to SMB shares. Some older printers and file servers may require NetBIOS to connect. (51119111)

To enable NetBIOS, you can create or edit the /etc/nsmb.conf file. If your system doesn't already have an /etc/nsmb.conf file, use the following Terminal commands while logged in as an Administrator:

echo "[default]" | sudo tee -a /etc/nsmb.conf
echo "port445=both" | sudo tee -a /etc/nsmb.conf

To disable NetBIOS, you can safely delete the /etc/nsmb.conf file.

  • 1
    This creating /etc/nsmb.conf and also adding signing_required=no to the file has worked for me
    – RoundPi
    Commented Apr 20, 2020 at 14:51
  • This answer plus the above comment re: signing_required=no did not immediately work for me, when trying to connect to my Seagate GoFlex NAS with the smb:// protocol via Finder. Instead, I did complete the above steps, but I connected with the afp:// protocol via Finder > Go > Connect to Server..., as described in this Apple Support thread. I used afp://<ip-address>/. Commented Aug 28, 2020 at 0:32
  • 1
    AFP is a protocol of its own and has nothing to do with SMB or NetBIOS.
    – PoC
    Commented Sep 22, 2020 at 9:09

I managed to fix it after I enabled the "Allow guest users to connect to shared folders" for the "Guest User" under the "Users & Groups" panel.


First, I used the activation of NetBios, which seemed to arrange the trouble. But, in fact, that was not good.

So, I tried to unify Working groups of NAS (D-Link and Synology), iMac and MacBook Pro and then I put IP of my Box as WINS Server. And it seems to be the solution (for me).

D-Link NAS use AFP and Synology SMB protocol.

PS : Forgive my poor English....

  • Could you list the IP addresses of the three devices and which IP you selected as my box as he wins server?
    – bmike
    Commented Nov 17, 2019 at 15:49
  • why is it "not good"?
    – lobi
    Commented Jan 28, 2020 at 16:53
  • Why it is no good ? Because sometimes I must connect manually to NAS and sometimes the connexion is automatic. Before Catalina, the connexion was always automatic.
    – Inazuma12
    Commented Jan 29, 2020 at 22:20

I have created a more extensive solution that has helped me. My target was to get my Apple TV, iPhone and iPad to be able to access my files on my Mac (10.15.4) I have confirmed it working using the following apps on Apple TV & iPhone:


• Infuse

• FileBrowser

• FileExplorer

Phase 01:

• Launch Terminal

• Type:

echo "[default]" | sudo tee -a /etc/nsmb.conf

echo "port445=both" | sudo tee -a /etc/nsmb.conf

Phase 02:

• Launch Settings

• Go to "Users & Groups"

• Create new user (Recommended: as "Share Only")

Phase 03:

• Launch Settings

• Go to "Sharing"

• Activate "File Sharing"

• Add folders/drives to share

• Add the new user with desired read or write permissions

• Click on Options...

• Activate sharing using SMB (Recommended: Activate AFP also)

• Under "Windows File Sharing", Activate the New user created and enter the password

Phase 04:

• Using Finder, Locate folder/drive to share & right click

• Click "Get Info"

• Unlock (small lock at the bottom right)

• Add new user with the same desired read or write permissions as in Phase 03

• Click the gear icon and "Apply to enclosed items..."

Phase 05:

• Using Finder, go to /usr/sbin

• Locate "smbd"

• Launch Settings

• Go to "Security & Privacy"

• Click the tab "Privacy"

• Click on "Full Disk Access"

• Drag and drop "smbd"

Phase 06:

• Reboot

• Verify all above modifications

• Done - You will be able to access the shared folders using the newly created user credentials

Warning: Changing permissions to /Users/YourUser/ (Or "~/") & its enclosed items will cause endless errors (Specifically ~/Library) Only recommended for folders and drives not containing User Directory.

You can skip "Phase 02" by applying "Phase 03" & "Phase 04" on an existing user, though this will weaken general security of your files (as per the warning by Apple under "Windows File Sharing"), and allow for dangerous modifications (specifically if the User Directory is a sub-directory that is shared)

  • This was done on my Desktop. I will Format my laptop and update to Catalina (Fresh install) and attempt again, skipping phase 01, to test if it was just the combination of the other phases alone that got it working or if phase 01 is actually required. Commented May 25, 2020 at 10:36
  • On the same desktop I did this on, I deleted the file /etc/nsmb.conf then rebooted. Accessing via the iPhone (VLC - SMBv1) seems to continue to work. I'll confirm once I have the laptop up and running. Commented May 25, 2020 at 15:47
  • Dragging /usr/sbin/smbd into "Full Disk Access" solved it for me
    – bluefirex
    Commented Jul 26, 2020 at 11:00

This may be helpful for someone who has been unable to connect to a network drive using SMB. I found a very simple solution.

I have a local network that includes a Mac mini server with an attached USB drive, and after upgrading to MacOS Catalina I was unable to mount the drive from any computer on the network.

I found many posts on various forums that reported the problem but none of the suggested "solutions" solved the problem for me. (And on one forum I was even chastised for reporting the ineffectiveness of two suggested solutions.)

Here's how I solved the problem:

On the Mac mini server I displayed the Info window for the attached USB drive and selected "Shared folder".

Now I'm able to access the drive from my other computers in the network.


I have the same issue after updating to macOS Catalina Version 10.15 Beta (19A487m)

I have a network drive connected to a router using SMB:// Its a 8TB readyshare.

This has always connected automatically and is primarily used as a backup. Since the update this has been unavailable and if I try to connect I get the same error as above.

If I try to browse it shows the drive but will not connect. This is shared with a Windows 10 machine and another Mac that can both connect as normal.

I did wonder if it was the way the drive was formatted that was causing the issue.

Any help would be appreciated.

  • 2
    Welcome to Ask Different :) The place is reserved for posting the answer to the original question. However, this post does not actually answer the question. If you have one, please consider editing your post and share it. If you have a separate question, ask it here. Else, consider deleting this post.
    – Nimesh Neema
    Commented Jul 1, 2019 at 17:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .