70

I'm running High Sierra on my older iMac. I recently loaded the Karabiner-elements.app but when I tried to delete it, a message appeared that said it was locked and couldn't be deleted. So I opened Get Info for it and confirmed that the app was locked. I couldn't uncheck the locked box so I clicked on the 🔒 icon at the bottom. The box where I can uncheck the lock feature is still greyed out.

enter image description here

I also opened a terminal window and navigated to the /Applications folder. I determined that the Karabiner app was there and I typed sudo rm -r Karabiner-Elements.app but I got a message that said Operation not permitted.

How do I delete this app?

1

6 Answers 6

118

It should be done in the app itself.

In “Misc” tab, press the "Uninstall Karabiner-Elements" button.

You can also uninstall Karabiner-Elements from command line.

bash '/Library/Application Support/org.pqrs/Karabiner-DriverKit-VirtualHIDDevice/scripts/uninstall/deactivate_driver.sh'
sudo '/Library/Application Support/org.pqrs/Karabiner-Elements/uninstall.sh'

https://karabiner-elements.pqrs.org/docs/manual/operation/uninstall/


For any other app/file which are locked, try to unlock it by unchecking the "locked" box in "Get Info" first.

If the box is greyed out, run the following in Terminal:

cd "/Applications"
sudo chflags noschg "Karabiner-Elements.app"

Then delete it by right click > "Move to Trash"

Read more about noschg at man chflags.

6
  • 4
    Just updated to Catalina and forgot Karabiner was installed, and it would not permit any kind of removal. The terminal command worked for me, thanks!
    – Nahydrin
    Commented Jan 23, 2020 at 21:28
  • 5
    After running sudo chflags noschg "Karabiner-Elements.app", couldn't delete with Move to Trash, but sudo rm -rf Karabiner-Elements.app deleted the app. Same for EventViewer. The uninstall script didn't work, maybe because I'd already deleted most of the app by hand. All this in Catalina.
    – Greg
    Commented Nov 13, 2020 at 20:39
  • @Greg didn't "move to trash" ask for root password ?
    – anki
    Commented Nov 13, 2020 at 20:53
  • @anki If it did I entered it. But I don't remember. I mostly just got something to the effect of you can't delete this.
    – Greg
    Commented Nov 14, 2020 at 3:04
  • 4
    Greg's experience is due to the fact that noschg allows the system, not the user to delete the app. In order to allow user to delete the app, you can try sudo chflags nouchg,noschg "Karabiner-Elements.app"
    – user2246
    Commented Feb 7, 2021 at 9:53
13

As of June 2023, this is the only possible way to delete the app:

You need to unlock files by the following commands in the Terminal:

sudo chflags nouchg,noschg /Applications/Karabiner-Elements.app
sudo chflags nouchg,noschg /Applications/Karabiner-EventViewer.app

After that, you can delete them in the Application folder

1
  • 2
    As of November 2022, this seems to be the only currently relevant answer.
    – jakob.j
    Commented Nov 15, 2022 at 20:08
4

I had forgotten I had installed this app, but accidentally deleted the kernel extension and uninstaller script. I was left with an app that could not be trashed or removed or moved in any way.

Solved it like this:

  • Download Karabiner-Elements
  • Install
  • Launch the app
  • Go to "misc" and uninstall with the uninstall button.
  • reboot

And then never install it again.

Really very annoying, I spent a lot of time trying out different suggestions but none of them worked. Changing the flags, changing the user, etc.

1

None of the scripts above or the documentation from Karabinar existed on my paths or worked...the only way I was able to do this was

  1. reboot my mac and kept holding command+r (this took me to recovery mode)

  2. while in recovery mode I went to Utilities > Terminal and typed

    csrutil disable
    reboot
  1. after rebootI typed
 sudo -i

and then

cd /Library/SystemExtensions 

and I saw a funny folder name like this FB393D41-2F97-4069-97E1-1F97B711EA3B ,

rm -rf that folder (be careful not to delete anything else)

  1. then
ps -ef|grep karab

and kill the job with kill -9 PROCCESS_ID

  1. went to application folders via finder and deleted Karabinar from there too.

it was a pain for me but happy I removed this...if I had known this would be this much pain to remove it, I would have not even installed at all to begin with..

3
  • never mind i forgot to do csrutl disable and then reboot original comment: I also have /Library/SystemExtensions/7...-2...-4...C/org.pqrs.Karabiner-DriverKit-VirtualHIDDevice.dext and when i try to rm -rf that directory I get 'Operation not permitted' - any thoughts? I don't know why there are no posts on it - but I am suspecting Karabiner Elements has to be spyware. I would like if someone installed it and had something like Charles proxy monitoring web traffic to see if Karabiner Elements is sending keystrokes to Jiangsu Qinheng Co., Ltd Commented Dec 18, 2020 at 13:34
  • did you try it as root ? (also check the sticky bit). Lastly if you found the post useful please give it +1 . also I suspect Karabinar is a spyware they have gone to great lengths to make sure , you cant' delete or stop the application easily !
    – grepit
    Commented Dec 18, 2020 at 16:00
  • I just did a full system restore. I got paranoid that the 'uninstall software' function on the karabiner elements software dumped some additional malware onto my computer. Just didn't want to worry about this anymore. Commented Dec 23, 2020 at 17:50
1

Open Karabiner-Elements, then go to the Misc tab. Finally, click on the Uninstall Karabiner-Elements button.

A picture is worth a thousand words:

Karabiner uninstall

Source: Karabiner-Elements - Documentation / Manual / Operation / Uninstall

0

hi guys this worked for me i hope it will for you too, just go to the Terminal :

bash '/Library/Application Support/org.pqrs/Karabiner-DriverKit-VirtualHIDDevice/scripts/uninstall/deactivate_driver.sh'
sudo '/Library/Application Support/org.pqrs/Karabiner-Elements/uninstall.sh'

if it says : Operation not permitted. then this :

sudo rm -rf /Applications/Karabiner-Elements.app
rm: /Applications/Karabiner-Elements.app/Contents: Operation not permitted
rm: /Applications/Karabiner-Elements.app: Operation not permitted

hope it works for you ;)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .