20

I'm running High Sierra on my older iMac. I recently loaded the Karabiner-elements.app but when I tried to delete it, a message appeared that said it was locked and couldn't be deleted. So I opened Get Info for it and confirmed that the app was locked. I couldn't uncheck the locked box so I clicked on the ๐Ÿ”’ icon at the bottom. The box where I can uncheck the lock feature is still greyed out.

enter image description here

I also opened a terminal window and navigated to the /Applications folder. I determined that the Karabiner app was there and I typed sudo rm -r Karabiner-Elements.app but I got a message that said Operation not permitted.

How do I delete this app?

42

It should be done in the app itself.

In โ€œMiscโ€ tab, press the "Uninstall Karabiner-Elements" button.

You can also uninstall Karabiner-Elements from command line.

$ sudo '/Library/Application Support/org.pqrs/Karabiner-Elements/uninstall_core.sh'

Documentation

| improve this answer | |
  • 2
    Just updated to Catalina and forgot Karabiner was installed, and it would not permit any kind of removal. The terminal command worked for me, thanks! – Brian Graham Jan 23 at 21:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .