2

I've been working on this problem for over 10 hours. First of all, I installed Mojave using the Mojave patcher on an older MacBook (The model number is A1278. It's a 2011 Macbook Pro) I completely erased my disk before installing Mojave. Here is the output of diskutil list:

    /dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage Local Disk              999.3 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

/dev/disk1 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Local Disk             +999.0 GB   disk1
                                 Logical Volume on disk0s2
                                 17B0E440-563B-4759-B442-CC8FE78F58DB
                                 Unencrypted

and sudo gpt -r show disk0:

       start        size  index  contents
           0           1         PMBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6         
          40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      409640  1951845952      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC
  1952255592     1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  1953525128           7         
  1953525135          32         Sec GPT table
  1953525167           1         Sec GPT header

Why am I still getting this error when I run boot camp assistant? I've already followed a guide that involved deleting any hidden Microsoft files in the EFI EFI partition. But I don't think it really did anything because as I said, I completely erased this disk before installing Mojave. I'm at a complete loss here, and I'm desperate for help.

EDIT: I know this question has been asked before, but from what I can tell, no one has had this exact problem. On the posts I see involving this problem you can clearly see Microsoft partitions in the diskutil list. I have no visible Microsoft partitions. I performed a clean install. So I'm at a loss for why I keep getting the error.

I used GPARTED to format the SSD and then reinstalled using the macOS Mojave Patcher ( http://dosdude1.com/mojave/#additional_info ), and I still have the same problem. I don't know what else to do.

  • Welcome to the site. Did you follow Apple’s erase and install procedure from a specific KB or web page? Sometimes “clean install” means a couple things. Also - Mojave patcher probably needs explanation unless you removed all remnants of that with an erase of the disk. I’d probably remove the edit and just state any more facts - what hardware - SSD / HDD disk, etc. Showing your references online for what guides you follow might be the best way for someone to spot what to suggest. – bmike Jun 18 at 22:18
  • Not sure how to reply to the flag, but here's the answer to your questions bmike. "Did you follow Apple’s erase and install procedure from a specific KB or web page?" I just used the disk utility on the Mojave patcher usb I made to erase the disk. And I followed the guide on dosdude1.com to install Mojave. The SSD I'm using is a crucial 1tb SSD. I'm tempted to perform a complete wipe of the ssd using a third party app like gparted, and then trying to re install Mojave on the SSD. – Jonathan James Jun 18 at 22:33
  • Sounds good - you don’t have to edit it. If after a couple days, no one has suggestions - you can revisit if it’s clear or you have some more information. – bmike Jun 18 at 22:38
  • I think it would be helpful if you could include the year and/or model identifier of your Mac. At this point, I believe the error message is correct and that you probably will not be able to use the Boot Camp Assistant to install Windows. – David Anderson Jun 19 at 5:20
  • Hi David, I tried replying to your answer on installing Windows without BCA, but I need 50 rep to reply. I'm desperate to figure this out so I thought I'd respond here. Sorry if it's against the rules. I followed the instructions on your answer, but when i tried mv efi nonefi, it said there was no such directory. And when I try to boot from the usb, I have no EFI boot option. I suspect this is because I did not properly convert my drive to gpt/mbr hybrid. But I'm at a loss. Please get back to me if you can.If theres any way I could contact you, that would be great. I would even pay you. – Jonathan James Jun 19 at 23:31

You must log in to answer this question.

Browse other questions tagged .