This question already has an answer here:

View from Disk Utility: Disk Utility screenshot

Output of diskutil (for this disk only):

/dev/disk6 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *80.0 GB    disk6
   1:               Windows_NTFS                         34.9 GB    disk6s1
   2:                      Linux                         10.7 GB    disk6s5
   3:                 Linux_Swap                         2.1 GB     disk6s6
   4:                      Linux                         32.2 GB    disk6s7

The first NTFS partition, "--", mounts just fine as read-only. But I can't get to either of the Linux partitions. I've tried mount, diskutil mount, and diskutil mount readOnly, but but they all result in

Volume on disk6s5 failed to mount
If the volume is damaged, try the "readOnly" option
If the volume is an APFS Volume, try the "diskutil apfs unlockVolume" verb

Also tried diskutil apfs unlockVolume, but it's not an APFS volume. Any ideas? Using macOS Sierra 10.12.6.

marked as duplicate by Tetsujin, Nimesh Neema, nohillside Jun 18 at 8:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I get that there's a related question that ultimately answers this. But to everyone who marked as duplicate: please tell me, of all the valid Linux file system types, how I was supposed to know these partitions were ext4? – kjekk Jun 19 at 0:30

macOS can't (actually won't - it could), it used to be possible with simple add-ons, but SIP has made most of these unusable.

There are paid options, but not sure if these are still usable with recent macOS.

You can read ext4 with a Linux Os, either a virtual machine, or boot from a live CD or image.

Not the answer you're looking for? Browse other questions tagged .