0

I believe I have already read all related posts on stack.

Hardware/Software: I’ve got an iPhone 6 with iOS 12.3.1 (before iOS 12.2).

Problem: Some apps are stuck in loading/waiting or are greyed out.

Cause: I guess my stupidity ;-) I tried to set up restrictions on a non-jailbroken phone. Trying several apps like flipd, space, break and kid protection tools that all need MDM-profile access. And my stupidity and ignorance led me to clicking on a link and activated the corresponding MDM-profile that promised jail breaking the device. I think it was through https://pangu8.com/jailbreak/12.2

Some of these official apps then remove the apps from your device during the restricted time (instagram, facebook, etc.), but need to reload them onto your device after the restricted time is over.

The support from one of the developers advised to remove the MDM-profile, which I did. And I de-installed the apps, etc. Everything worked fine. But at one point it just didn’t anymore and apps got stuck in waiting/loading/greyed out (can’t start/stope/delete app).

In one support-response I’ve got this info: “Your apps will return automatically when these directions are followed. Please note that the Full Lock feature requires an internet connection and an interruption or disconnected network can affect the functionality.” (emphasis added by me)

I wasn’t aware of that.

I have tried deleting/starting/stopping the loading, connecting to different wi-fi networks, start/stop directly from App Store, I have done several soft and hard resets for network settings and the complete phone. I have then restored from a backup. I have tried restoring from several backups, but they issue stays the same. I thought an update would fix it, so I have just updated from iOS 12.2 to iOS 12.3.1, but to no avail.

I assume that a hard reset and starting from scratch without restoring would “fix” it. And that would be my last resort.

Why then did I not do that yet? A) There are a few apps (Google Authenticator and iMala (for counting mantras) I need the data from that are not backed up by iCloud or another cloud service. And - as long as they are not installed completely - don’t show up in iTunes “File Sharing”.

I hoped that I could recover it using the method as displayed on this post https://dpron.com/recovering-google-authenticator-keys-from-ios-backups/. It seems that it wouldn’t work with iOS 12. I haven’t tried it yet.

Any ideas are well appreciated.

  • Steve
  • 1
    Welcome to Ask Different. What is your backup strategy? Do you have a backup that was taken prior to the start of all this? – fsb Jun 17 at 11:34

You must log in to answer this question.

Browse other questions tagged .