0

Title says it all. Installed (successfully, no errors) Java via HomeBrew on a fresh install of Mojave. From Terminal, I get the expected responses when I run things like which java and java -version (12.0.1 if that matters), but a desktop application I installed is telling me that it cannot load the runtime environment.

Another machine I have, same application and OS version, but I installed Java using the Oracle downloader, no errors and no issues. So I'm assuming that I need to set an environment variable or something, but I'm not sure what.

  • What desktop[ application and what does its installation instructions say about requiring Java? – Mark Jun 16 at 14:56
  • @Mark It's not a large scale app, nobody you've heard of. The docs don't say anything about it, it's not covered in its FAQ but the error I mentioned comes up if it's not installed. Given that it works fine when I install it from the Oracle site, I'm thinking it has something to do with how the JDK is registered when installed via Homebrew. – Paul Jun 16 at 15:28
  • More likely how the app looks for Java e.g. Eclipse has the path in a file in the app. The most obvious file is Info.plist but look at all .ini and .plist as see if anything – Mark Jun 16 at 16:12

You must log in to answer this question.

Browse other questions tagged .