An ongoing problem: my MacBook Pro (i5, 2.4ghz, 15") won't sleep while charging. I close the lid, but I don't get the pulsing "sleep light", it just stays fully illuminated. If I listen closely, I can hear hard drive/fan activity.

This has been a problem since purchasing the machine in June of 2010. In retrospect, I should've taken it to the Genius Bar, but I was confident that an eventual system update would fix the problem... it hasn't. I even wiped the machine clean and reinstalled Lion (due to so me stability issues with the initial release of Lion), and that helped... for a while. Now the problem is back. I've even tried a different MacBook charger to no avail.

I've researched this issue before but none of the solutions that users suggested have worked (including various 'pmset' commands and also tinkering with EnergySaver settings). Any advice?

4 Answers 4


You may want to look into the sharing options as well as any other programs that may be keeping the computer awake. If you exit all running programs (you may want to consider checking programs that are running in the background as well) and turn off all sharing under 'System Preferences' -> 'Sharing' and close the lid does it still exhibit the same problems.


I know you've tried similar things, but hopefully with a few more details this will work for you. Please note: using pmset -g for troubleshooting this problem is about getting information, it doesn't actually make changes.

In the Terminal, run

pmset -g assertions

You should see something like:

16/08/13 1:24:58 PM GMT+
Assertion status system-wide:
   PreventUserIdleDisplaySleep             0
   CPUBoundAssertion                       0
   DisableInflow                           0
   ChargeInhibit                           0
   PreventSystemSleep                      0
   PreventUserIdleSystemSleep              1
   ExternalMedia                           0
   DisableLowPowerBatteryWarnings          0
   EnableIdleSleep                         1
   NoRealPowerSources_debug                0
   UserIsActive                            0
   ApplePushServiceTask                    0

Listed by owning process:
  pid 7928: [0x00001ef8012c14ca] PreventUserIdleSystemSleep named: "there are active torrents"

Kernel Assertions: None

If it includes PreventUserIdleSystemSleep 1, then there is some software that is preventing the sleep. The section Listed by owning process: shows relevant processes, which you can kill if necessary (e.g. kill process with id 7928 by running kill -9 7928).

This solved the problem for me. There were two relevant processes: Internet Sharing and a BitTorrent client. With sharing disabled, the sleep on lid close functionality was restored. I left the BitTorrent client running (and therefore PreventUserIdleSystemSleep remained set), because I don't actually want it to sleep when idle, just when I ask it to.

I found the solution here.


I would recommend trying both an SMC (System Management Controller) and PRAM (Parameter RAM) reset.

  • For the SMC reset, shut down your computer and leave the charger plugged in. Once your machine is completely shut down, press the +ctrl++power button keys at the same time for about 2 seconds. What you should see is your charger light change from orange to green back to orange when you let go. When you see the lights switch colors like this, your SMC has been reset.
  • To reset the PRAM, shut down your computer. Press the power button and immediately press and hold the ++P+R keys until you hear the startup chime sound twice. After the second time, you can let go and your machine will boot normally.

You can do both the SMC reset and the PRAM simultaneously if you like.

Try this and let us know what happens.

  • Thanks to everyone for your replies. I've tried the SMC/PRAM resets before but tried them again anyhow. I got the same results as usual: the issue went away for a day or two, but soon returned. As for @kyle-cronin suggesting that I turn off sharing: the only sharing service that I have turned on is Web Sharing, allowing my system access to a locally-stored .PAC file. However, this problem began long before I started using the PAC, so I don't think they're connected. Any other suggestions? I feel like I'm starting to reach the end of my rope with this one.
    – brijazz
    Commented Jan 14, 2012 at 12:36
  • I have two more suggestions for ya. To isolate whether or not it's something related to software, and if it is which part, try enabling the guest account on your MacBook, logging out of your user account and logging into the guest account and testing the issue. If it still does it, move to the next step. You may have to take a trip to the Apple Store for this one, unless you have the right resources. Try booting to another Mac operating system, preferably the same one you have. If you have an external drive and an OS installer, you can make one. Genius Bars have them already made...
    – Matt Love
    Commented Jan 14, 2012 at 18:06
  • ...and can test this for you, as well as run a quick hardware diagnostic called MRI. Try the guest account thing first since it's easiest. If it's not doing it in the guest account, we know it's an issue with your user account. If it's not doing it in the external OS, we know it's an issue with your OS. If it's still doing it in both, it's likely a hardware issue. If your MacBook Pro is in good shape and out of warranty, you can have it sent out for a full repair for a flat rate of $310 (that's what it was when I was Apple a few months ago, anyway). Let us know what happens.
    – Matt Love
    Commented Jan 14, 2012 at 18:09

Go into System Preferences > Sharing and turn off Internet Sharing and File Sharing.

You can run pmset -g assertions again in terminal and you will see the 1 is gone that counts. After restarting your computer it will go to sleep while plugged in now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .