I have a Mac Pro running 10.6.8 Server and a MacBook Pro (Mid 2010) running Lion 10.7.2. I would like to configure a mobile account for my wife to use. The idea is that she'll be able to access her user account locally on the server using Fast User Switching, but be able to log into the same account on my MacBook Pro and have the home folder sync through a mobile account.

I was able to do this when my Mac Pro had Lion Server on it, but I downgraded to Snow Leopard Server because Lion Server caused a lot of issues and dropped several key features from Snow Leopard Server.

Right now, I have her account configured to Create Mobile Account at Login. I am able to log into the account locally, but if I attempt to log into the account from the MacBook Pro, it says "Unable to log into account at this time".

I have the user account's home directory on a separate drive. The correct directory is set in Workgroup Manager, and the Users directory is set as an automounting share in Server Admin>AFP. The user I'm trying to log into has Read/Write access to the Users directory and the home folder, as well as ownership of the home folder.

The MacBook Pro is joined to the OD server through System Preferences>User Accounts>Login Options>Network Account Server. The MacBook Pro is also added as a computer and is in a computer group in Workgroup Manager.

Is there something I'm missing to configure this mobile account to be able to log in?

2 Answers 2


It should work. When the user tries to login, do you see any errors in the system.log or secure.log?

Have you tried to completely delete the account from the local computer, unbind it from the server, rebind, restart and try to login again? (of course backup first)

  • I haven't had a chance to check the system log, but I do remember seeing something odd in the kerberos log. It said something along the lines of unable to authenticate user. I'll have to take a look at it again to give you the specifics, but I won't be able to do that until I get home from work later. I haven't tried removing the account, but I have created new accounts with home folders on the same share and they have the same issue.
    – Matt Love
    Commented Jan 12, 2012 at 14:08

You probably have moved on from this in the past three years; but for posterity, here is another possible solution. Check the directory server status in the 10.7 machine's Accounts preference pane. It may be red, since you reset everything on the server when going back to 10.6. If so, just remove it and add it back again and the login problem should go away.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .