Has anybody been able to use a VPN connection to CheckPoint from a Mac?

My test until now:

  • Tried the standard Html page to login, no success because the java applet cannot be loaded
  • Downloaded a full featured Checkpoint client, no success (connection not made)
  • Tried IPSecuritas, same results

Until now the most interesting result were installing the SNX client from CheckPoint and then creating a .snxrc profile, after that snx is able to connect like so

Check Point's Mac SNX
build 800005012
Please enter your password:

SNX - connected.

Session parameters:
Office Mode IP      :
DNS Server          :
Secondary DNS Server:
Timeout             : 12 hours 

Problem is that at this point it seems to connect (because IP address are correct and also because if I provide a wrong password it give me the correct unsuccesful logon message) but if I do a ifconfig I see that the interface created from Checkpoint do not have an IP address and also if I try to add one using ifconfig I'm not able to ping any machine on the remote network

ifconfig en7
ether 54:55:43:44:52:00 
Check Point Virtual Network Adapter

Any idea about I can assign a proper IP address to the interface so that I can use the remote network?

Regards Massimo

1 Answer 1


I was able to run the client making some modification to the wireless router configuration:

  • The DHCP server now gives addresses that start with 192.168.2 instead of the old 192.168.1
  • The subnet mask of the local IP address is now
  • You run OSX in 32 bit mode keeping the 3 key pressed during boot

After these changes the subsequent call to SNX (configured as described above) was able to associate the proper IP address (that in my configuration was, last number changes from connection to connection) to the en7 interface created by SNX and so I've a valid IP address for the router on the 192.168.2 network and one for the office on the 192.168.1 network.

I'm still convinced that something can be done using also the ifconfig command to properly assign IP address, but for now having a connection it's enough for me, I'm posting the result of ifconfig if someone can describe me how to proceed:

ether 54:55:43:44:52:00 
inet netmask 0xffffff00 broadcast
Check Point Virtual Network Adapter

See also http://www.phillo.it/?p=13

Regards Massimo

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .