I am unable to print from my MacBook pro to an Epson 5500 proof printer. The printer works with an old G4 Mac. But it stubbornly refuses to work from the MacBook running Lion. The computer knows the Epson is there and allows the setup procedure. However when I send a file, the print status goes to Printing and then almost immediately to Ready, suggesting that the job has been completed.

The printer only has a USB interface. I have tried different cables, but all to no avail. I have even sent the same file from the G4 and the PowerBook.

Any suggestions please? Yes I do have a driver for it.



  • Try killing the driver in the print/scan preference pane, then reloading it online (hit the plus button at the bottom of the field).
    – Richard
    Commented Jan 11, 2012 at 21:36

2 Answers 2


Have you tried sharing the printer from the G4 box? This could be a case where the older system is running a set of printer drivers which work well with the printer, but the newer system has either those specific drivers removed, or they just don't work correctly.

To do this, on your G4 box, go to System Preferences > Printer, and select the printer you are trying to do. In there, there should be a checkbox that says "Share this Printer". Once you have done that, you should be able to see it in your print dialogs through Bonjour.

See if that helps.


Unfortunately, I think you're out of luck.

Looking at Epson's website, it doesn't seem that Epson ever wrote a driver for Intel-based Macs for this printer. Epson's last driver release for this printer was in 2004 for Tiger on PowerPC Macs.

The printer is at least ten years old, and I know its probably not what you want to hear, but I think it's time for a new printer. As you've already encountered, you can't get software support any longer, and if you need parts and/or ink, they're likely to be in short supply.

I hope this is helpful.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .