0

Safari is bugged in my macbook. It's a macbook air 2019 with mojave 10.14.5

The problem is I can't delete bookmarks nor save new ones on it because it ask to keep or remove firefox bookmarks, which according to Safari, where imported on january 1st 4001.

safari date error

I've pressed every button, but nothing happens

I've tried deleting the cache and even restoring to another mac my timemachine backup to see if it's solved, but no, so before I tried to reinstall from zero, I would like to know if I can do something else.

1

The first thing I would do is Clear History from the Safari menu. After that quit and re-launch Safari while holding down the Shift key. That will launch Safari in Safe Mode and disable any third party extensions.

If Safari behaves itself after that, disable your extensions and re-enable them one at a time.

Failing that, more extreme measures are in order. I would start with a preferences clean. Quit Safari and then in Finder hold down the Option and select the Go menu and then "Library" from that menu.

Once the Library folder is open look for a folder or folders with Safari in the name and move the contents of each to folders on your Desktop. Then look for a Preferences folder in the Library folder and open it up. Look for any file/folder with Safari in the name and move them to the desktop. Once the library folder is clear of Safari-related files Try safari then and see how things are working.

If things are still not working properly I would download and install the Combo update for the current version of your macOS. Search on "combo update mac os 10.14.5" (or whatever your current version is). It will lead you to a large file on apple.com. Download and run it. It will update your OS and will usually fix problems such as this.

If that still does not fix the problems let us know.

  • It didn't worked, the date is still 4001 and if I try to remove any bookmark it doesn't do it and can't save new ones. – Daniel Jun 13 at 13:43
  • You may have gotten a particularly difficult bit of malware that is doing this. There are malware utilities out there like Malwarebytes, AVG and the like that would be worth trying. Failing that I would back up the files you absolutely can't do without and reformat the HD and reinstall the OS. Don't use Migration Assistant to copy your files back as it could very well copy the damaged or infected files too. Copy only what you MUST have. Install Apps fresh. Other people may have suggestions on what else to do or why something else may be going on. – Steve Chambers Jun 13 at 15:11
  • thanks, I'll try some malware removal utilities, and if they doesn't fix it I would reinstall everything because I've tried already with migration assistant and the problem is still there. – Daniel Jun 13 at 17:02
  • I've tried MalwareBytes and Avira and they found nothing. I guess it's time to start fresh with the mac – Daniel Jun 13 at 17:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .