0

I bought my MBP with Turkish layout and I am using in U.S. layout. On my external keyboard, I have apostrophe ` symbol behind the 1, as it should be, but on my Mac's keyboard, with same settings, there is the § symbol (and I don't know what is that) I want just apostrophe symbol behind the 1 key, do you have any idea to solve this problem?

  • Sounds like you have an ISO keyboard but want an ANSI layout [only the US keyboards have those keys there, so 'should be' is a very limited market] - do you want the keys where you think they should be, rather than where they're printed? This is a bit out of date, but gives most layouts - support.apple.com/HT201794 – Tetsujin Jun 10 at 17:36
  • Yes, my both keyboards are ISO keyboards. Internal is in Turkish layout, external is in UK International ISO with 105 key. However, in Input Sources tab I saw, Mac treats like as an ANSI to my external keyboard. idk why... – kemalicecek Jun 10 at 19:31
  • § is a section symbol - usually used when citing legal code, for example, US Code title 18 section 242 would be abbreviated 18 USC § 242. (And ` is a backtick or grave accent, ’ is an apostrophe - although many people abuse backtick and single quote to `fake' smart quotes in plain text, as I did around the word ‘fake’) – dr.nixon Jun 10 at 21:36
1

You can use Karabiner to customize shortcut on your keyboard as you please, give it a try !

  • I looked but didn't wanna spent any time and make my Keyboard Setup Assistant setting reset and now two of my keyboards prints § now... But I am using it to open hotkey window of iTerm so that's okay... – kemalicecek Jun 10 at 20:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .