0

I tried using disk utility both in the regular mode and recovery mode. I tried using the terminal and this is what I get:

MBP2011:Volumes admin$ diskutil repairDisk /dev/disk2
Repairing the partition map might erase disk2s1, proceed? (y/N) y
Started partition map repair on disk2
Checking prerequisites
Checking the partition list
Adjusting partition map to fit whole disk as required
Checking for an EFI system partition
Checking the EFI system partition's size
Checking the EFI system partition's file system
Checking the EFI system partition's folder content
Problems were encountered during repair of the partition map
Error: -69854: A disk with a mount point is required

This external hard drive has a lot of information I don't want to lose, does anyone else know what I can do?

  • This could be a mount problem. There is a 3rd party app called Mountain that allows user to mount drives. The app is available from the app store. you might give it a try. – jmh Jun 9 at 1:45

You must log in to answer this question.

Browse other questions tagged .