I hope you might be able to help me out since I am completely stuck in my attempt to perform a clean install of High Sierra on a late 2009 iMac (model number A1311 – does not have Internet recovery) in which I have just inserted a brand new SSD right out of the box using the thermal HDD sensor from OWC. The old HDD got corrupted (or at least, that’s what I think happened), so I swapped it with a 500 GB SSD.

For obvious reasons, I did not clone the old drive. Instead I have prepared a 16 GB USB 2.0 with what should be a bootable version of High Sierra 10.13.6. I made this on a Windows 7 PC using TransMac and a High Sierra .dmg file. I haven’t been able to test if this has worked as intended as I do not have another Mac around.

Anyway, when I switch on the iMac, I hear the familiar chime (so far so good – pre-testing passed) and then I get the expected blinking folder with a question mark on it. Now, I thought that I would be able to boot from the USB by holding the option key on startup to get to the Startup Manager, but the only thing that happens is that I get a mouse pointer (arrow), then nothing. I haven’t had any success on any other startup key combinations – can’t activate verbose mode, either. I don’t know if verbose mode depends on a bootable drive, but with the old drive – after it failed – I could still get into verbose mode and was able to see part of the startup process until it got stuck.

I have also tried installing from DVD by holding down C on startup, but it spits out the DVD after what appears to be a few attempts to read it (it does not have any scratches). I have tried the original install DVD (Snow Leopard) and a home-burned version of Yosemity. No success. The keyboard I am using is an original USB-wired Mac keyboard and I have tested on another computer that the keys are working. Any ideas? I’d be very helpful if someone with expertise in the quirks of late 2009 iMacs could suggest some other things to try. Thanks.

EDIT: I forgot to mention that I have also tried resetting the NVRAM using the keys: Option-Command-P-R, but it didn't make any difference either.

  • Have you tried doing a network recovery? See support.apple.com/en-us/HT201314 for details. You can start the recovery process with Option-Command-R to "Upgrade to the latest macOS compatible with your Mac." (support.apple.com/en-us/HT204904)
    – pjs
    Commented Jun 8, 2019 at 22:31
  • @pjs. As I have pointed out in the question, the late 2009 iMacs cannot do network recovery. Commented Jun 8, 2019 at 23:46
  • any change you have a firmware lock? Hold down the option before you power on your mac. You should get into startup manager unless you are locked out by a password lock or a hardware error. Commented Jun 9, 2019 at 1:00
  • 1
    @historystamp I tried your suggestion. Got the same result with only a mouse pointer appearing. Nothing to indicate a lock. I've had the iMac from new and never added a lock. If there is a hardware issue, would the chime play? Where is the Startup Manager stored in the hardware? Is it something that might be restored? Commented Jun 9, 2019 at 8:41
  • I could repeat this question word for word - with the difference that I am trying to repair an 2007 imac. Strange. Commented May 15, 2020 at 18:13

1 Answer 1


I would say you need to take your machine in for repair. You have detached all external devices that you can: with possible exception of mouse&keyboard?

Reset machine Sometimes if volumes don't appear in Startup Manager (what you get when you hold down the Option key at startup), you need to reset the Mac's PRAM, NVRAM. Shut down the Mac, then power it up, and before the screen lights up, quickly hold down the Command, Option, P, and R keys,( I hold down the keys before pressing the power on button, but requires some contortion. ) until the Mac has chimed twice more after the powerup chime.

Andy Betts lists machine specific variants for this procedure in this article:


  • Thanks for the suggestions: However, I have already reset the NVRAM using the Option-Command-P-R keys until it chimed twice. According to the link you have supplied, the commands do not apply to late 2009 iMacs since they are Intel based (they have Extensible Firmware Interface instead of Open Firmware). It only applies to PowerPC-based Mac computers. Commented Jun 9, 2019 at 21:27
  • I adjusted my article. Commented Jun 10, 2019 at 18:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .