1

Recently, I upgraded to Mojave and I have discovered that filesystems to which I connect with Finder appear to have rw access, but I cannot change or create files. Similarly with NFS mounts. Having a file server that I cannot write to is not useful :-)

This worked prior to the upgrade, so I suspect Mojave, but I have been looking for similar issues for hours with no luck.

Any insights?

Config: Macbook Pro running Mojave 10.14.5, file server Netgear ReadyNAS OS6.10.1

Example (Finder->Go->Connect to Server->smb://fserver/pictures):

$ mount | grep pictures
//tarsa@fserver/pictures on /Volumes/pictures (smbfs, nodev, nosuid, mounted by tarsa)

$ ls -ld@hbefO /Volumes/pictures/
32 drwx------  1 tarsa  family  -   16K Jun  8 10:40 /Volumes/pictures//

$ touch /Volumes/pictures/foo
touch: /Volumes/pictures/foo: Permission denied

Example (mounting with nfs):

$ mount -o rw -t nfs fserver:/run/nfs4/data/Pictures ~/mnt

$ mount | grep mnt
fserver:/run/nfs4/data/Pictures on /Users/tarsa/mnt (nfs, nodev, nosuid, mounted by tarsa)

$ ls -ld@hbefO ~/mnt
3 drwxrwxr-x  1 tarsa  family  -  1.3K Jun  8 10:40 /Users/tarsa/mnt/

$ touch ~/mnt/foo
touch: /Users/tarsa/mnt/foo: Permission denied
  • In your first example you try to touch a file directly inside /Volumes (not on any mounted drives), is this really what you want to do? Also, can you please run mount and add the lines relating to your volumes to the question? – nohillside Jun 8 at 14:42
  • You can look at all permissions with ls -la@hbefO Suggest you look at each directory in the path. Add d option to force ls to give directory info as needed. – historystamp Jun 8 at 18:53
  • Please show the output of the 'mount' command for both of your examples, – Marc Wilson Jun 8 at 23:37
  • Thanks for the feedback. I have updated the examples to include the proper touch, ls for all the permissions, and provided the mount information. – Greg Tarsa Jun 9 at 18:08

You must log in to answer this question.

Browse other questions tagged .