2

I have an old iPad 3 (on iOS 7.0.4) and I have not used this for a long time, so did not update. If I turn this on, then it asks for iCloud password. I remember the password.

Then one of the two cases occur:

Case 1: If my all other iOS devices are closed, then it does not recognize the password and keep asking for the (correct) password in each 2 seconds.

Case 2: If I turn on my iPhone 7 (iOS 12.2), then in my phone it says something like “another device in ... location is trying to access your account.” There are two choices: Give permission or reject. I guess this is 2FA.

After I give permission to my old device, I get a confirmation code in the iPhone and enter it on my old iPad together with the iCloud password.

It seems to work ( because I see all check marks on the iCloud section of the settings of my iPad) for a couple of minutes. In that time interval, I don’t get any error messages in my devices. But after a few minutes, case 2 repeats over and over again.

At least, I can operate the old iPad without any issue for some minutes but entering the password and confirmation code in each 5 minutes is annoying.

I don’t want to update my iPad because I am not using it actively. Unless there is an easy fix, I consider backing up the iPad and never use it again.

Thanks in advance for your suggestions.

Edit 1: I added iOS versions. I thought that I can not turn off 2FA because on Apple’s webpage it says “if you already use two factor authentication you can no longer turn it off” under the question “Can I turn off two-factor authentication after I’ve turned it on?” in the link https://support.apple.com/en-us/HT204915.

Edit 2: It seems that I partially fixed it. As I said in case 2, I got stuck in an infinite loop: I gave permission to my iPad from my iPhone, got a verification code, entered it in my Ipad, it temporarily resolved the situation, but then the same pop-up message appeared on my iPhone a few minutes after, hence the vicious cycle. To break this cycle, I tried turning off my iPhone 7, then my iPad 3 continued operating normally without any trouble.

I also tried restarting my iPad (keeping the iPhone closed) and strangely, my iPad started recognizing my iCloud passcode too (remember in case 1, I had said that when all my devices were closed I had the trouble with the iCloud code in my iPad, but the iPad 3 confirmed the code now.) But still, when I turned on my iPhone, the same message was appearing continuously in each say 5 (or a few) minutes.

  • Hi! please add iOS versions. Also to isolate 2FA in debugging, please turn it off on your iPhone and continue using the iPad. – ankii Jun 7 at 4:30
  • In a nutshell - is this really that you can't change the passcode unlock on the iPad and wish to have a different setup while avoiding the normal software update process to fix any bugs on iOS? – bmike Jun 7 at 11:13
  • @bmike I did not actually understand what you meant. I know the passcode for iCloud, the code is approved in my iPhone for example. Somehow, my iPhone only temporarily confirms my other device, that’s the problem. Probably, this has to do with the old iOS version in my iPad. To update to iOS 8.4.1, I need to delete a lot of things because there is no enough space. I just don’t want to lose time on that because I am very rarely using this iPad, if there is an easy fix I will go with that. Otherwise, I will probably update so delete a lot of things by manually checking them. – sedergine Jun 7 at 15:14
  • @sedergine Yes 2FA cannot be turned off, sorry for that. Can you go check at appleid.apple.com if iPad is recognised under the devices section. Also signing in and out from iCloud (in Settings) on iPad is also a troubleshoot. Also your iPhone is on compulsory 2FA and iPad is not. Quoting the site: "For the best experience, make sure that you meet these system requirements on all of the devices you use with your Apple ID: iPhone, iPad, or iPod touch with iOS 9 and later" – ankii Jun 8 at 5:22
  • @ankiiiiiii No worries. I tried signing in & out, but it did not work. My iPad 3 was not recognized, it was used to be recognized in the past. As a result, it works, if my other devices are closed (it also works in the other case, but my other devices are alarmed frequently). Either, anytime I use it, I will turn off my other devices or I update my iPad 3. Do you know if there is a risk of failure during the update of an old iPad after few years, e.g. should I be concerned about losing data so that I don’t have access to my files. In other words, do you suggest backing up everything? – sedergine Jun 8 at 22:18

You must log in to answer this question.

Browse other questions tagged .