I just bought a Macbook Pro early 2015. It only has 128 GB of storage so I decided to upgrade it with a 1 TB NVMe SSD from Crucial. Off course, I also had to buy the adapter to convert the M.2 plug to the Apple one. I installed Mojave and it actually works a lot better that I expected!

Now, I want to do a dual boot with Windows 10. I tried the BootCamp assistant with many differents version of Windows 10. Everything works untils the first Windows boot where everything freezes and I get a BSOD (stop code critical process died...). Then I tried with the default Apple SSD and it worked just fine.

I also tried to do a "self" intaller with a USB key wihtout much more success...

I'm kinda out of idea here and I cannot find any article on google talking about problem with NVMe and BootCamp.

  • 1
    I wonder if you need to slipstream the windows drivers for the ssd and possible adapter into windows. Also, have you ruled out virtualizing windows instead of worrying about drivers? Super glad the fast storage works on macOS side. – bmike Jun 7 at 2:11
  • Yes I have a VM installed on my MAC but I work in IT so I need Windows to have full access to the hardware in order to have everything work properly. About the drivers, I will check but I dont think there is any driver for the adapter as it's just a socket redirector! There is definettely some for the NVMe however. – etiennnr Jun 7 at 13:31
  • Nice use case - Apple provides all windows drivers you need for the hardware as part of Boot Camp historically so it's unlikely this is the case if you have hardware that's perfectly OEM. Apple often puts custom firmware on all parts - so YMMV when you drop what might seem equivalent into a Mac. – bmike Jun 7 at 22:05
  • I'm having the exact same issue with BSOD via Boot Camp with a Crucial 1TB SSD on a Early 2015 MacBook Air. Tried the same things of installing different versions of Windows 10 and disabling graphics driver updates but this seems to be a compatibility issue with the SSD. – Nathan Massey Jul 29 at 22:20
  • Yes this is definitelly a NVME SSD driver issue. I actually changed my mind and started using a VM because I never found a fix for this... – etiennnr Jul 30 at 16:06

You must log in to answer this question.

Browse other questions tagged .