Go to watch any video instantly. Click on play video. It'll say that it's preparing to load. Then it switches to the video screen for half a second, then back to the preparing to load screen, then dumps me back to the browsing for instant videos screen. So the video never played at all.

Any idea on how to fix this?

4 Answers 4


I managed to resolve this by changing my DNS server to Google's Not ideal, but it worked. Still, any ideas why this is happening?

  • 1
    Are you on Comcast? ;) Dec 2, 2010 at 16:27
  • @David Time Warner, actually Dec 2, 2010 at 17:19
  • There was news back in December that some AppleTV owners were having issues getting content from the iTunes store. Apparently, these were power users that switched OpenDNS or Google DNS, and that wasn't playing well with the way that Akamai (who does iTMS caching) handles downloads. I was having problems with Netflix on the ATV, so tried switching my DNS back to those of my ISPs. And it fixed the issue. So it may work for the iPad app as well.
    – bpapa
    Feb 5, 2011 at 7:03
  • After spending hours restoring my iPad and trying every imaginable trick to get Netflix working finding this answer through Google saved the day. Thanks. Feb 26, 2011 at 3:32

This happened to me when I upgraded my router to dd-wrt firmware. If you did this, then you have two choices.

  1. Change your ipod (ipad) DNS settings to Google as suggested above with or
  2. Disable dnsmasq for both DHCP and DNS. This could cause you to be vulnerable to a rebind attack. http://en.wikipedia.org/wiki/DNS_rebinding

Here is a post on the dd-wrt forum http://www.dd-wrt.com/phpBB2/viewtopic.php?p=481907

Good luck


Development versions of DD-WRT now include an option to disable the dns-rebind protection in DNSMasq. This solves the problem. OpenWRT has the same problem as DD-WRT, since it uses the same DNSMasq package.

In OpenWRT, you can edit the /etc/ppp/options.pptpd file and remove the stop-dns-rebind line, or just comment it out with a #.

Note that while you will still be vulnerable to a dns-rebind attack, so are almost every home and small-office router on the planet, so you will be in good company! :)


I haven't seen this issue myself, but perhaps the iPad app is behaving strangely under 4.2.1 in regards to multi-tasking? Try "killing" the app in the recently used apps menu, and see if that fixes it.

  • FYI: this happened before 4.2 with multi-tasking Dec 1, 2010 at 16:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .